Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to add aliases to /etc/hosts it causes connection problems with my internet. Whereby it is connected to my network and it still says it has internet access, but i am unable to view web pages (returns connection error page) or download etc, it does this every 10-15 minutes for 5 minutes. When I take the aliases out of the hosts file and restart apache, it is fine. I am running Ubuntu 12.10.

Here is my Hosts file.

127.0.0.1 localhost sitealias
127.0.1.1 ubuntu


# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

I want to know whats causing it, but I would also like to know how you would go about diagnosing the cause for future references.

share|improve this question

migrated from stackoverflow.com Apr 11 '13 at 17:07

This question came from our site for professional and enthusiast programmers.

    
Please expand on "Problems". What exactly doesn't work? –  daxlerod Apr 11 '13 at 17:49
    
Try to have your /etc/hosts file consistent with your /etc/hostname file. Otherwise you can experience network problems. –  jap1968 Apr 11 '13 at 18:04
    
@Danzabar: Please link your Stack Overflow account in to Super User, and then edit your question, so we know that the edit is coming from you and not a random anonymous user. –  Scott Apr 12 '13 at 18:47
    
@daxlerod: i have edited the question to expand on the problem; –  Danzabar Apr 13 '13 at 8:16
1  
1) technically, /etc/host entries are not aliases, but lookups. 2) Do you run a web proxy? 3) can you use ping and other tools to connect? Say, does a ping www.google.com or a telnet www.google.com 80 do something? 4) what's that ubuntu address supposed to be? All of the 127/8 network is defined as loopback, it looks suspicious to me. –  Rich Homolka Apr 15 '13 at 2:36

2 Answers 2

Base on what is posted in question

127.0.0.1 localhost sitealias
127.0.1.1 ubuntu

I can foresee you will be having trouble access website sitealias (unless you run a local webserver hosting that particular site).

On the other hand, you should have no trouble accessing other site. (I am assuming your dns setup is correct, as you don't have trouble without the sitealias in /etc/hosts.)

The reason you have trouble accessing sitealias when it is presented in /etc/hosts is that

127.0.0.1 localhost sitealias

actually make sitealias point to IP address 127.0.0.1, which is your own machine.

IP address 127.0.0.1 is a loopback address, which is always the local machine. You can read more about it in wikipedia page.

If you are trying to use apache as proxy server, then you should not put sitealias in /etc/hosts, but configure firefox proxy settings accordingly.

share|improve this answer
up vote 0 down vote accepted

After some further investigation I have found out, that this problem is actually specific to Virgin customers with superhub. As documented here

I fixed this issue by switching to "Modem only" mode.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.