Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
As i experiences sublime ,it have some issue with showing UTF-8 ,but it save theme just fine. – user180445 Apr 11 '13 at 18:08

Just go to File → "Save with encoding" and select your preferred encoding.

share|improve this answer
this will change file encoding. – interlude May 5 '13 at 20:46
@interlude water is wet – aug Jun 8 at 22:26
@aug I have no idea why I wrote that comment 3 years ago. – interlude Jun 11 at 12:22

If you want to set UTF-8 as your default encoding, you can also do this:

Preferences -> Settings - User -> Add this line of code

"default_encoding": "UTF-8",


share|improve this answer
Just to make sure... "UTF-8" means "UTF-8 without BOM" right? I assume it would be "UTF-8 BOM" or something like that otherwise – dominicbri7 Aug 1 '13 at 13:37
Looks like it's "UTF-8 with BOM" for with BOM. – ruffin Nov 5 '14 at 14:34

This is the correct configuration:

    "Default_encoding": "UTF-8",
    "font_size": 9,
share|improve this answer
Please note that this is an English speaking site so your answers should be in English. You also do not need to put a signature in your answer as your name automatically appears below the answer. Welcome to Superuser. – Mokubai Apr 16 '14 at 19:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.