Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Has anyone successfully gotten a SpinRite ISO image to successfully see a USB device?

Steve Gibson, on his SpinRite FAQ page, says that you can add a USB device driver to a DOS boot diskette and FreeDOS may then be able to recognize USB devices. I've successfully tested this with SpinRite image on a floppy disk. However, I primarily like to use SpinRite from an ISO file in a VM and would love to be able to access USB devices from there as well. Unfortunately my skills have proven inadequate.

The point at which I've thrown up my arms was I had successfully repackaged the SPINRITE.EXE in an ISO image with my USB device driver using ImgBurn, making it bootable using an image file I had extracted from a previously created SpinRite.iso using Bart's Boot Image Extractor. The SpinRite image loaded normally with VMWare Player, but my USB devices would not show up in the partition selection screen (I did add the USB Controller to the VMWare Player and told the player to Control my USB device before SpinRite had come up, I even rebooted the VM as well). I also tried injecting the device driver into the preexisting SpinRite.iso with WinImage, but Steve has apparently made the 1.44 MB formatted ISO image appear as though it has 1,529,8XX bytes and therefore full.

share|improve this question
    
I forgot the exact details, but you have to add the drivers to the config.sys file and possibly autoexec.bat. DEVICE=a:\drivername.sys something like that. –  cybernard Apr 11 '13 at 22:08
    
I assume your using the current version of SpinRite? This would actually be very useful, so I am going to follow this question, and send in a question to Steve through the normal channels and hope for a response on Security Now! –  Ramhound Apr 12 '13 at 11:44
    
If the ISO burnt to a CD allows you access to your USB devices, I'd say the problem lies with VMWare's support for USB devices from a DOS VM. Which USB driver are you using anyway - Motto Hairu? DUSE? –  Karan Apr 12 '13 at 20:41
    
When I open the .iso with WinWAR, it only contains the SPINRITE.EXE. There is no config.sys or autoexec.bat to speak of. Simply dropping the driver file on to my floppy image of SpinRite worked without modifying any files.I am using the latest version of SpinRite. –  Matthew Apr 15 '13 at 21:32
    
The device driver I'm using is Usbaspi.sys from HDDGURU, again it does work on my floppy image of SpinRite. When I told my VM to control the USB device, the USB device was released from my host system, Windows 7 so I assume the VMWare Player is working properly. Other VMs I have are able to control USB device successfully this way. –  Matthew Apr 15 '13 at 22:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.