Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I sync my iPod Nano or iPod Touch to my iTunes library, iTunes (version 9) will say that my computer is not authorized to play my DRMed songs. So, I give it my username and password to appease it. It then tells me that my computer is already one of my five authorized computers, and it completes the sync.

It does this every time I sync. What is going on?

share|improve this question
    
what version of iTunes, 9? –  warren Oct 21 '09 at 2:32
    
Yes, it is iTunes 9. –  Chris Dwyer Oct 21 '09 at 2:49
add comment

3 Answers

up vote 1 down vote accepted

I ran into this once with iTunes 7.... The library was partially corrupted, or the permissions on the file were wonky...

I ended up moving the music library, creating a new library, and then re-importing all the music. I didn't lose any data, except for play counts...

share|improve this answer
add comment

This is a bit odd. Try deauthorising your computer by going to the Store menu, then Deauthorize Computer, then just follow the prompts. Then Authorise your computer again using your favourite method.

If this does not work, try deauthorising all computers: From the Store menu, select View my account. Once you login, go down to Deauthorize all computers and follow the prompts. Then Authorise your computer again using your favourite method. Hopefully, everything should be working fine after that.

If you are still experiencing problems I suggest you lodge a support ticket with Apple to get them to try and rectify the problem.

share|improve this answer
    
Word(s) of warning on deauthorizing all: (1) you can only do it once per year and (2) I think you need to have authorized 5 computers before you do it. –  Adam Ryan Oct 21 '09 at 3:09
    
They claim that you can only do it once per year, but I have done it more than once... And no you need to have more than 2 or 3. You don't need to be at 5. It's a standard Apple suggested debug method. –  Benjamin Schollnick Oct 21 '09 at 10:19
add comment

Some applications have problems storing information in registry, probably due to the more strict approach in Windows 7 when it comes to user rights.

Try to run iTunes as an administrator (Right click on the program icon, and choose "Run as administrator") and see if it helps.

share|improve this answer
    
Thanks for the suggestion. I ended up refreshing my library. –  Chris Dwyer Dec 8 '09 at 23:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.