Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been trying to setup my DNS server, and I have got powerdns configured to do basic stuff.

My issue is that RPT records doesn't resolve correctly when I run dig command against public DNS server like 8.8.8.8, and it only resolve when I run it against my own Public DNS Server.

Below output displays DNS query results against my DNS server.

$ dig @My-public-DNS-server -x 192.158.14.100

.

; <<>> DiG 9.7.6-P1 <<>> -x 149.13.158.192
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 56897
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;149.13.158.192.in-addr.arpa.       IN  PTR

;; ANSWER SECTION:
149.13.158.192.in-addr.arpa.    18262   IN  PTR **mydomain**.

however if I run dig against public DNS server it doesn't return anything.

$ dig @8.8.8.8 -x 192.158.14.100

Why is that? can someone help?

share|improve this question
    
What are you using to publish your public DNS records? Sometimes it takes awhile to pick up public DNS, depending on a few factors. –  jmreicha Apr 12 '13 at 15:04

1 Answer 1

up vote 1 down vote accepted

Do you have a delegation for the reverse zone or is it delegated to your service provider?

in-addr.arpa delegations generally derive from an assignment from a Regional Internet Registry (or RIR) for example ARIN if you're in the USA or Canada)

They assign a block of network addresses and along with it the delegation for management of the reverse lookup domains corresponding to that address block.

If you don't have an address block assignment from ARIN (or whoever the RIR is for your geographic region) you probably don't control your reverse lookup domains, so when a client tries to do a lookup by traversing from the DNS root there is no delegation for them to follow to find your server to get the answer you are trying to give.

To find out who does have delegation for the subdomain of in-addr.arpa that you are concerned with you can manually follow the chain of DS records from the root or you can use dig +trace

share|improve this answer
    
I checked with my ISP, and they told me that because my allocation is less than /24 they would have to manage it for me. –  user1007727 May 2 '13 at 20:36
    
That's not unusual. Delegating smaller than a class C is possible but it's a pain because the delegations are best set up on byte boundaries. You should probably just ask them to insert the records for you, but if you have a need to change them frequently you can ask them about accepting Dynamic DNS updates from you, secured by a pre-shared TSIG key. –  Michael McNally May 2 '13 at 22:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.