Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In the terminal on Solaris 5.9 (ksh), I don't see the characters when typing. I can see the input only after the return key is pressed. I checked terminal settings with stty -a it shows:

echo echoe echok -echonl -noflsh -echoprt echoctl echoke

meanwhile I have inspected stty -a on my linux box and it's the same:

echo echoe echok -echonl -noflsh -echoprt echoctl echoke

I know the stty -echo and stty echo can disable/enable echoing in the console. It did on my linux, but didn't affect anything on the Solaris terminal where I'm suffering the issue. So, what could it be?

share|improve this question

migrated from stackoverflow.com Apr 12 '13 at 10:46

This question came from our site for professional and enthusiast programmers.

    
Try rerouting your stdin back to dev/tty, as in this related question: stackoverflow.com/questions/8994593/… – Paul Sweatte Jun 19 '13 at 19:33

You must log in to answer this question.

Browse other questions tagged .