Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My iTerm 2 window is up against the menubar at the top of the screen.

When I resize the window vertically from the top to the bottom, a small gap is always left. It never resizes down fully to the bottom.

I think this is because it is only resizing within whole terminal rows and columns.

Is there anyway to stop this behaviour, I can't bear to look at this much longer ;)

share|improve this question

4 Answers 4

Press "Control" while resizing will let you overcome the resizing limit. But this is still annoying because I have to manually resize after using BetterTouchTool's window snapping.

share|improve this answer
    
This was the perfect solution, I'm sure there's a reason it's not the default behavior but I wish it was. –  Pablo Feb 6 at 18:08

I was suffering the same annoyance until today.

Open Preferences > Profiles > Text > Regular Font > Change Font and play with the font Size and/or Vertical Character Spacing. Test your changes by making an adjustment, resizing iTerm, making another adjustment, and rinse/repeat until the window size lands where you want. On my MBPr, using the Monaco font, a Size of 10 and Vertical Spacing of ~1.25 did the trick.

Edit—Another possible solution:

For the Default profile, open Window and set Settings for New Windows > Style to either Bottom of Screen or Top of Screen and Settings for New Windows > Columns to 134.

New iTerm window title bars will be hidden and iTerm will be flush to the menubar but it's not possible to resize or move the window without first dragging out the iTerm tab (mine are bottom alined so you can't see them in the screenshot) at which point the title bar reappears, taking us back to square one.

I was able to use a pre-made Moom preset to move the window into place without the title bar present; that's how in the following screenshot I got iTerm without title bar positioned on the right:

iTerm Flush

share|improve this answer
    
Thanks, nice workaround, but I don't want to change the font size ;) I just think I'm going to have to live with the gap :( –  jordelver Sep 12 '13 at 8:22
    
I edited in another possible solution to my answer. –  leoj3n Sep 12 '13 at 19:08

If you set the default height of new windows to something like 999 rows, they fill up the screen vertically. Also uncheck these settings:

  • Appearance > Hide tab bar when there is only one tab
  • General > Adjust window when changing font size

I always use iTerm in full screen. I have set Profiles > Window > Style to Fullscreen and unchecked General > Use Lion-style fullscreen windows (so there's no animations and ⌘H is not disabled). There is a bug where the menu bar is always shown in Resume'd custom full screen windows though.

share|improve this answer
    
Unfortunately, none of these options worked. Setting the window height to 999 still leaves a gap and the other options don't seem to have any affect :( I would like to use iTerm fullscreen, but I have dual monitors and it makes the second monitor unusable by blanking it out. –  jordelver Apr 12 '13 at 21:34
    
I don't have two displays at the moment, but even if you don't use Lion-style full screen windows? There's also the 4 pixels taken up by the Dock. Disabling the Dock isn't really practical, but you can change desktop backgrounds (or the bottom parts) to black. –  ؘؘؘؘ Apr 13 '13 at 10:22

(iTerm2 Build 1.0.0.20131124@OS X Lion 10.7.5)

What I found out is that when I enable the toolbar I do not have any resizing issues (in addition I experience the same gap horizontally to the right of the window). But as soon as I disable the toolbar (View -> Toggle Toolbar) I can resize the window horizontally and vertically to the maximum without any gaps at the bottom/right side of it.

Feels like a bug, not a feature. :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.