Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The problem seems easy at the first glance but is a little more complicated. The machine (Lenovo laptop) has Windows 8 Pro, a Intel Core i7 and all 4 cores run at 100% . The fan runs at full speed the whole time. When rebooting the fan spins down and starts to spin up once the start screen comes up. I tried to kill all unneded processes but it had no effect, there is also no additional anti virus software installed.

In the task manager the System Idle Process is shown with 98%-99% as well as in procmon ( sysinternals ).

I am pretty sure that the idle process is not the root cause, but there has to be one and the only thing changed were windows updates including a new driver for the integrated intel graphics card. This could have something to do with it but the high cpu load didn't start until I put the device to sleep and woke it up a few times.

I also don't want a quick solution to the problem but rather find out what causes it, any ideas are appreciated

UPDATE 1: I ran xperf to gather more detailed information:

xperf -on latency -maxfile 256 -filemode circular
xperf -d trace.etl 
xperf trace.etl

The CPU usage in the graphs is normal, a few spikes but average cpu usage. To me it seems this problem is caused by the system thinking there is a high CPU load ( which shows everywhere in windows ( taskman, procmon, perfmon )) and therefore spinning up the fan. I have to look at the CPU temparature to verify, if this is the main cause I only have to find out who spins up the fan, this could be windows but also a lenovo driver

Update 2: Okay this is critical as the CPU temp is constantly at 110°C so something really does cause the CPU to work

Update 3: The heavy load doens't occur with Windows 7 and already starts at the login screen of Windows 8

share|improve this question

2 Answers 2

up vote 3 down vote accepted

I found the cause. A hardware dependant software set all internal performance switches to high performance. The last time I used it it crashed and left the settings at that state. After starting the software and letting it exit gracefully the problem went away.

share|improve this answer
    
You should "Accept" this answer so that the question is shown as answered - it'll let people know immediately what fixed the problem and where they can check on their own machines if this happens to them. This was a very interesting issue, good to know and thanks. –  Mark Allen Apr 12 '13 at 18:19
    
The rules of StackExchange prevent me from doing this. I have to wait two days before I can accept my own answer. –  PaulFreund Apr 15 '13 at 12:35
    
In fact, even when you can't find the app causing mode switch, it should be possible to go to power management settings and switch to "Optimal" profile. That way idle CPU will drop frequency and voltage, and so will lower power consumption/dissipation. –  LogicDaemon Jan 15 at 17:57

Check for some other hidden processes.

Also try to uninstall some recent apps you installed.

share|improve this answer
5  
Your answer is very short and does not go into details. Please be more precise with your answer. –  Simon Apr 12 '13 at 12:06
    
okay i will do that –  mecyborg Apr 12 '13 at 13:01
    
If it's system idle process in task manager, that is it indeed. It means it's not some other process, so no need to check that. And now, after right answer is found, you know CPU can waste a low of power even when idle. –  LogicDaemon Jan 15 at 17:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.