Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to delete a file in a folder which was created way before I had Windows 7 it says:

You need permission to perform this action.

You require permission from the computer's administrator to make changes to this file.

But I AM the administrator. My account belongs to Administrators group. What the hell?

On a similar note, all the programs that don't have a GUI and are shell extensions can't create or modify files anywhere and Windows will never ask for my permission, so they basically won't work. How do I fix it?

The biggest question: why do I need to "run as administrator" when I am administrator already?

share|improve this question
1  
Tried all of that, but still doesn't work. I have UAC turned off, I have taken ownership, I am an admin, yet it still complains that I need admin permission to move a file. Same problem with deleting/renaming files/folders too. And it appears to be random files/folders. And I have also made sure no processes have a lock on the files/folders. I really hope someone can help me... Thanks. –  user114697 Jan 21 '12 at 19:05
    
@David Ellams: Same here; I tried what's listed here, and I still can't get rid of a certain blasted file that's giving me errors in project setup. –  David Thornley May 4 '12 at 21:39

3 Answers 3

up vote 5 down vote accepted

Have you tried to take ownership of the folders? Right-click > Properties > Security > Advanced > Owner and Take ownership as yourself (not administrator).

share|improve this answer

Reason is UAC (User account control). You can read more about UAC in this article for example.

When UAC is enabled, all user accounts—including administrative accounts—run with standard user rights.

So to perform tasks that require administrative rights you must elevate the rights of the application.

The reason you can't delete a file from before installing Windows 7 is because you are not owner. To delete it run Windows explorer (or any other file manager) as administrator.

To run Windows Explorer ad administrator, type explore in search field of Start menu then r-click on Windows Explorer in search results and select Run as administrator.

share|improve this answer

From How to Take Ownership & Grant Permissions to Access Files & Folder in Windows 7:

Windows 7 has implemented addition security mechanism to prevent accidental or intentional file or folder modification by not allowing users other then owner of file or folder to access it. Hence in case if you need to access, modify or delete such files or folder you need to take ownership first then assign rights or permission to respective users.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.