Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to use sc, the classic Unix spreadsheet calculator, mainly because I want to be able to look at some csv files nicely formatted in my terminal. I installed sc 7.16 but am seeing some strange behavior that I can't seem to fix.

When I start up sc, if I type, say =, to try to set a numeric value for the first cell A0, and it gives me a prompt like so

i> let A0 = 

so then I type 1 and press enter

i> let A0 = 1

and then I get

A0 (10 2 0) []
syntax error: let A0<= = 1

This seems unexpected and I'm not sure how to even go forward. I see the same sort of problem when trying to read in .sc files.

Further details: running Mac OS X 10.6.8 and installed sc via macports (though I'll note that I also tried building from the sc 7.16 source and but the version I got from this displayed the exact same error).

share|improve this question
    
I can confirm that the procedure you describe works as expected on my Linux. You're not doing anything wrong as far as I can tell. – terdon Apr 12 '13 at 17:12
    
Given that, I may have to solve this problem with the build myself. Anyone have any ideas on what's happening here that I might be able to fix? – G Gordon Worley III Apr 12 '13 at 17:29

You must log in to answer this question.

Browse other questions tagged .