Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just upgraded my Comcast internet, and my wired speeds vary from 58 Mbps to 70 Mbps (per speedtest.net).

I have a WRT610N router, and I'm only getting around 20-25 mbps from the wifi.

Things I have tried:

1) On channel 11, no other wifi signals in range are any higher than 6.

2) Switched between 20Mhz signal and 40Mhz signal. (Slight improvement with 40, but only about 2 mpbs)

3) Turned off CTS (Minor improvment)

4) Turned on Frame Bursting (Maybe a minor improvement, did at same time as CTS, so I'm not really sure which one caused the slight improvement).

5) Updated firmware of everything involved (router, wifi card, etc.)

From what I understand even a bad wireless-N network should be able to reach at least 75mpbs in practical speed, so what am I doing wrong here? Is it just my router? I am using DD-WRT, should I switch back to the standard Linksys firmware?

Any other suggestions? I've done 2 days worth of googling to try and find a solution to my problem, and still haven't figured it out.

UPDATE:

1) Switched back to Linksys firmware (speeds went up to 30 Mbps)

2) When I try to use the 5GHz, my wifi doesn't even show up. (Trying to fix that now).

Thanks for the responses.

share|improve this question
    
I don't think this difference is unexpected. –  Daniel R Hicks Apr 12 '13 at 15:53
    
You need to get off 2.4GHz. –  David Schwartz Apr 12 '13 at 15:57
1  
If you use HT40- (40 MHz) on channel 11, you will interfere with APs on channel 6 (your secondary channel is 7). –  BatchyX Apr 12 '13 at 16:01
    
does your laptop support the "mimo" N standard ? –  dashboard Apr 12 '13 at 16:10
    
What type of WiFi connection are you using? 20-25 Mbits/s sounds like 802.11g? –  ernie Apr 12 '13 at 16:10
show 1 more comment

1 Answer

Have you tried setting the network mode on the router to Wireless-N only, to force an N connection?

From my understanding the Protege R835-P56X ships with the Intel Wireless N 1000 by default, and only 2.4 GHz antennas, which is why you're not seeing the 5Ghz, and probably why your speeds are limited.

You could likely replace the WiFi card, and add a third antenna with a bit of tinkering, as described in this forum post.

share|improve this answer
    
Yes, I have set the router to only Wireless-N (no G/B/etc). I also have an iPad 3 that I can run speedtest on, and only get around 20-25 with both the 2.4Ghz and 5Ghz. –  apichel Apr 12 '13 at 22:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.