Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I took a 320 gig hard drive, shrunk the partition for Windows to 40 gigabytes, and cloned the partition. I'm trying to restore onto a 250 gig drive. I keep getting either a failed partition table, or clonezilla asking if the disk is too small. I've disabled size checking and anything to do with partitioning. I've tried everything and I still can't figure this out. Even tried DD, but when creating the initial partition, gparted fails with "Not a block device, refusing to create...."

Any thoughts? I have yet to find an issue like this since my partition is shrunken.

share|improve this question
1  
You sure the image is only of the 40GB parition? –  Ramhound Apr 12 '13 at 16:30
    
Yep. It shows 40 gb when I go to restore, but it then fails to create the partition table and asks if the disk is too small. –  Joseph Apr 12 '13 at 19:29
    
The bad news is it came from a larger hard drive so it isn't going to happen. This is NOT locigal to me, but I have hit this wall before. The only way to succeed is to do a partition copy and copy that specific partition. –  cybernard Apr 13 '13 at 20:10
    
Yea, I agree, that's not logical. I did use partition copy. I didn't copy the whole disk. Same thing? –  Joseph Apr 14 '13 at 19:20
    
copying a partition copy 1 part of the disk if the whole disk is 1 partition then it is nearly identical. The biggest difference is if you have 2 or more partition then only 1 will be copied. Also there are a couple small reserved areas that are not copied on a partition copy that are on a disk copy. –  cybernard Apr 15 '13 at 3:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.