Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.
Description:    Ubuntu 11.10
Release:    11.10
Codename:   oneiric

I have a lot of folders and files with ??? ???? ??.txt - like file names when I do

$ sudo mount -t vfat /dev/sdb1 /media/some/folder

My external HDD is really fat32. Following a couple of suggestions, I need to

$ convmv -f cp1251 -t utf-8 -r --notest folder/

but enca can't define encoding of the file(s). So, I've tried several encodings by try-and-check and it didn't work. I need to decide which files to delete and which to leave. So, 1) how to mount external HDD fat32 to show filenames correctly? 2) How to convert filenames encoding if I do not know encoding?

Update

$ sudo dosfsck -a -v /dev/sdc1
dosfsck 3.0.9 (31 Jan 2010)
dosfsck 3.0.9, 31 Jan 2010, FAT32, LFN
open: No such file or directory

Rebooting the system and remounting it solved this magic. But now I face a problem of

rm: cannot remove `somefilehere': Read-only file system

As I understand, the filesystem on external HDD is corrupted. Also dd_rescue is probably my choice but if I could repair safely, I'd like to.

update2 Solved problem partly by

$ sudo mount -0 remount,rw /path/to/mountpoint

But still can't remove some files.

sudo chmod 777 -R /path/to/par

causes : Input/output error

share|improve this question

1 Answer 1

It shows the file names that way, where ? is the Unix convention for "unknown/non-displayable character". You could:

  • You can specify mount codepage=... for VFAT
  • ls > somefile, and then look at the file to try to identify the character coding, perhaps file helps
  • od -c can help too
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.