Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I set my editor variable like so:

git config --global core.editor "`which emacsclient` -t -s"

and get this output whenever I want to edit the message during a commit

emacsclient: aliased to /Applications/Emacs.app/Contents/MacOS/bin/emacsclient -t -s :      
emacsclient:: command not found
error: There was a problem with the editor 'emacsclient: aliased to
/Applications/Emacs.app/Contents/MacOS/bin/emacsclient -t -s '.
Please supply the message using either -m or -F option.
share|improve this question

Did you checked the output ofwhich emacsclient command? I bet it is

emacsclient: aliased to /Applications/Emacs.app/Contents/MacOS/bin/emacsclient

Anyway, your global git config is located ~/.gitconfig file, so you can check and edit it.

share|improve this answer

Setting the full path "/Applications/Emacs.app/Contents/MacOS/bin/emacsclient -t -s" and not the alias to be the editor worked for me.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .