Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

I'm using Windows 7. I want to set Explorer's default location to "My Computer", whether explorer.exe is launched via the "Run" command, via command-line or via a shortcut. That's why I don't want to use a shortcut with a parameter.

I've done it in the past by tweaking the registry, but the default location was reset to Libraries after an update and I can't find the solution again.

This question isn't a duplicate of this one. The solution given there doesn't work on Windows 7.

share|improve this question

marked as duplicate by slhck Feb 25 at 13:14

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Out of curiosity, do you happen to know which Windows versions the answer in the other question applies to, so we can tag it accordingly? –  slhck May 18 '13 at 14:14
    
I don't know, sorry. –  Cutter May 18 '13 at 23:10
    
I would like for Explorer to default to `c:` for me. I asked this question but I've deleted it so that I could just up-vote and promote this question. Please note, I'd really prefer to do this through the Registry, if this is possible. I'm not interested in doing this with a third-party, hotkey app. Adding a 50 rep bounty. –  RLH May 20 '13 at 15:37
    
@slhck: IMO the accepted answer to that other question is valid for XP, whereas the AHK script provided by JMD is valid for Vista+. –  Karan May 20 '13 at 15:37
    
Are you interested in registry hacks like this one or these ones ? –  harrymc May 21 '13 at 10:21
show 3 more comments

2 Answers

By removing the following registry key, the Libraries will be hidden from the navigation pane and when launching via Win + E, Windows Explorer will default to the virtual Computer folder. If you apply this solution along with @Qwilson's then it should take care of everything except for launching from the Run prompt.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\{031E4825-7B94-4dc3-B131-E946B44C8DD5}

After you delete the key, you may need to log off, or restart before it takes effect.

In order to take care of running from the Run prompt, the only solution I could find would be to change your habit from typing explorer to typing shell:mycomputerfolder.

Note: I also found it very helpful to have the Homegroup feature and services turned off. When I tested this in a Virtual Machine with the Homegroup feature on, some launching methods would default to selecting the Homegroup.


Sources:

http://www.askvg.com/how-to-disable-libraries-feature-in-windows-7/

In Windows' Run command line, how to open "My computer"? (@paradroid's answer)

share|improve this answer
    
Note that simply removing that registry key does not disable the Libraries feature, it just hides them from the navigation pane in Windows Explorer. On the first link in my answer there is a registry patch file (.reg) that will disable the Libraries feature if you want to go that far. –  druciferre May 23 '13 at 2:21
    
Why the down vote? –  druciferre May 23 '13 at 20:32
add comment

I'm not exactly sure how to directly get this done via registry, but this option works well for me

  • Right click on the explorer icon (on taskbar)
  • Right click on Windows Explorer
  • Select Properties
  • Change the target to: C:\windows\explorer.exe shell:::{20d04fe0-3aea-1069-a2d8-08002b30309d}
  • Press OK

enter image description here

share|improve this answer
2  
This doesn't solve the problem, if you open Windows Explorer by use of the Windows Hotkey. –  RLH May 20 '13 at 17:25
    
Are you referring to win+e? Because every machine I've ever done this for works in the same manner. Is there any additional info you could offer up about the window behavior e.g. what does open when using the hotkeys. Also, another variation to the target is explorer.exe /e,::{20d04fe0-3aea-1069-a2d8-08002b30309d} –  Qwilson May 20 '13 at 19:25
    
When you say right-click on the explorer icon on your taskbar, what are you talking about? In my case, I have a pinned folder, but I have to click it, and then right-click on the option that is titled "unpin this option from the taskbar" to see the Properties option. Regardless, modifying the target of the Win Explorer shortcut didn't fix it. Could you add a screenshot? –  RLH May 20 '13 at 19:30
    
Sure... You're going to end up right-clicking twice. Once on the pinned icon and again on "Windows explorer". You select properties from there. I'm not sure I can add the pic to the comments so I'll attach to my answer... –  Qwilson May 20 '13 at 20:32
1  
@Qwilson: your answer obviously doesn't solve the problem as it was formulated. It is explicitly asked to avoid the "shortcut" solution. –  Cutter May 21 '13 at 17:03
show 8 more comments

Not the answer you're looking for? Browse other questions tagged or ask your own question.