Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a second Chrome profile set up, in addition to Default, using --user-data-dir="..\User Data\Second Profile". I'd like to use the custom stylesheet I have in my default profile in the second profile.

In case it matters, I'm using Solarized from here: gist.github.com/anonymous/1258555. (Super User won't let me post more than 2 links since I don't have 10 reputation.)

I copied the User Stylesheets folder with the stylesheet in it from %localappdata%\Google\Chrome\User Data\Default\User Stylesheets to %localappdata%\Google\Chrome\User Data\Second Profile\User Stylesheets, but that didn't work. Just in case it was some kind of weird bug with that particular profile, I created a new one and tried the same thing, which also didn't work.

I only found one person asking the same question, in Google's product forum and then in a Google group, and the answer just says to create the User Stylesheets folder with Custom.css in it, which I'd already done.

What else can I try that might get this to work?

Thanks!

share|improve this question
up vote 0 down vote accepted

TL;DR: Check about:version for the Profile Path and put the User Stylesheets folder in the folder listed there rather than in the folder you've specified in --user-data-dir="some folder".

I tried a couple more things after writing up this question, and did finally get it to work. Oddly, it was a post explaining how to find Chrome version info that helped me. I wanted to include in my question which build I was using - couldn't remember if I switched it to dev on this computer or not - and the "about:version" page includes a full profile path.

The path it says is actually %localappdata%\Google\Chrome\Application\User Data\Second Profile\Default, rather than %localappdata%\Google\Chrome\User Data\Second Profile, so I moved the User Stylesheets folder to there, and it finally worked. :)

Hopefully this will save someone else from wasting time trying to figure this out.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .