Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I cannot bring up the fullscreen mode in my guest Ubuntu 12.04 machine using Windows 7 when the external screen is not plugged in. I tried disabling the second screen in the guest OS and I get the same error:

Can not switch the guest display to fullscreen mode. You have more virtual screens configured than physical screens are attached to your host.

Please either lower the virtual screens in your VM configuration or attach additional screens to your host.

Any ideas?

share|improve this question
add comment

2 Answers

Disabling the monitor in the guest OS is not enough. You have to disable the monitor in the configuration of the virtual machine. This means also that if your guest is suspended, you have to discard its state and restart it.

share|improve this answer
    
and where in the configuration do I disable the monitor? –  130490868091234 Apr 14 '13 at 11:18
    
In the manager, right click on the virtual machine. Settings -> Display -> Video -> Monitor Count –  Marco Righele Apr 14 '13 at 11:38
add comment
up vote 0 down vote accepted

After some work, it turns out the best option so far is to:

  1. Switch the Ubuntu screen to fullscreen.
  2. Disable the second screen in Linux Ubuntu 12.04 after it's been switched to full screen.

The problem right now is that I need to repeat this process every time which is still not ideal...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.