Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just installed iTerm2 on my computer and oh-my-zsh. Everything is working fine except that it's displaying "➜ ~ git:(master) ✗" as my PS1. I'm not sure what this token is called. Anybody?

I'm trying to change it to something shorter and to remove my git branch information. It shows it for every dir.

I've checked both ~/.bashrc and ~/.bash_profile

Any help would be great. Thanks.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Both .bashrc and .bash_profile are to be used by bash, not zsh. Check zsh manpage for details on startup scripts.

share|improve this answer
    
Thanks I'm markig this as the right answer as it really did push me in the right direction. I needed to edit it in ~/.oh-my-zsh/oh-my-zsh.rc –  Hassanin Ahmed Apr 14 '13 at 12:12

Oh-my-zsh uses its own themes. You should not edit its startup file in the ~/.oh-my-zsh folder, as this one will be changed anytime you update oh-my-zsh and you would lose your customizations.

Check your ~/.zshrc startup file, which Zsh created for you and oh-my-zsh should have modified on its first execution.

There, you'll find something like:

# Set name of the theme to load.
ZSH_THEME=...

Replace the ZSH_THEME with any of those you can find here. Some themes don't display Git information at all.

If what you merely want to change is the prompt (i.e. the thing that's shown before your input), setting PS1 manually in your .zshrc will do – many options for that exist as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.