Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When accessing Google products ( / etc...) I often get a :

Oops! Google Chrome could not connect to
Try reloading: google.­com
Additional suggestions:
Access a cached copy of google.­com
Search on Google:

error on Chrome. This happens on all my browsers, and all my devices that are connected to my router.

It seems to be a DNS issue with my router and specifically Google. What is this problem, and how can it be solved? It's been like this for about 2 weeks now.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

One way to test if it's a DNS issue is to try using Google's public DNS servers - and 

Instead of the ones you are currently using.

You may also have some sort of malware or virus issue.

share|improve this answer
Would adding Google's public DNS server affect anything else? What could be the cause of this? I doubt it's a malware issue because several devices (including iOS). I run a Mac that I regularly scan and has no issues. – darksky Apr 14 '13 at 15:08
adding googles dns won't affect anything else other than to speed it up. Its provided by google but its just a public DNS server. – Toby Allen Apr 14 '13 at 15:14
Some DNS servers "hijack" (or "proxy" if you prefer) DNS requests to Google (OpenDNS does, or did at one time) so by using Google's DNS servers you are sure to get proper DNS resolution for Google sites unless you ISP is hijacking port 53 requests. – user168261 Apr 14 '13 at 15:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.