Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Ubuntu 12.04, I have a VirtualBox virtual machine running Windows Server 2008.

I have a directory set up to mount /media/windows, which is chmod 777.

When I mount the share from the Windows server under Ubuntu, the profile of /media/windows changes, and I no longer have write permissions.

Here is my mount command

sudo mount -t cifs -o username=Administrator,password='password',rw //WIN/SHARE /media/windows
share|improve this question

migrated from stackoverflow.com Apr 15 '13 at 6:33

This question came from our site for professional and enthusiast programmers.

    
It looks like a missing comma between the password and rw options. – Ben Voigt Apr 15 '13 at 4:14

I found a solution. I added my Linux user id to the mount statement and it handed ownership of the mounted directory to me...

sudo mount -t cifs -o username=Administrator,password='password',uid=1,rw //WIN/SHARE /media/windows
share|improve this answer
    
You should mark your answer as "correct" then, even if it's your own :) – Mathias Conradt Mar 11 at 11:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.