Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I m using VMware for my linux version Ubuntu 11.04 and i have searched for /boot/grub/menu.lst file but this file was not there. Why??

I was creating a new kernel in virtual linux but unable to create because of proper configuration file.So how i will get the proper config file for ubuntu 11.04 for kernel version 2.6.34??

share|improve this question

migrated from stackoverflow.com Apr 15 '13 at 11:10

This question came from our site for professional and enthusiast programmers.

    
What boot loader are you using? –  arkascha Apr 15 '13 at 5:13
    
i m using grub boot loader –  BalluSingh Apr 15 '13 at 5:47
    
If that really is the case (I don't know Ubunut) then I suggest you list the layout of /boot/grub. –  arkascha Apr 15 '13 at 5:57
add comment

1 Answer

up vote 3 down vote accepted

Since Ubuntu 9.10, the default bootloader is now grub2 (package name grub-pc). It works differently than grub 1.

The main configuration file is /boot/grub/grub.cfg, but it is autogenerated and you should not modify it directly. To generate it, run the update-grub command, which is just a wrapper for grub-mkconfig. What it does is read the configuration file /etc/default/grub and execute all scripts inside /etc/grub.d.

share|improve this answer
    
I have done this for new kernel but after that the new kernel was not responding,black screen appears after selecting that option. Any reason or solution for this. –  goodies Apr 23 '13 at 9:23
    
After compiling the new kernel, have you generated a new initrd image? Have you run update-grub after generating the initrd? If you have done these steps, it is probably that the error is in your kernel compilation, not in grub. –  Carlos Campderrós Apr 23 '13 at 10:49
    
yes i have done all these steps after compiling..but it ws not returning out from black screen.. –  goodies Apr 23 '13 at 10:56
    
It then seems a problem with your kernel. Try to compile the kernel with the same settings you have in the default ubuntu kernel. You can find them at /boot/config-KERNEL_VERSION –  Carlos Campderrós Apr 23 '13 at 11:10
    
I have compiled it with default settings but it was not working.I dont know what will be the problem. –  goodies Apr 23 '13 at 11:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.