Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

Specs:

  • Motherboard: Crosshair V Formula-Z
  • CPU: AMD FX-8150
  • Memory: G.SKILL F3-2400C10Q-16GTX Trident X 16GB 4X4GB DDR3-2400 CL10 240PIN 1.65V Quad Chann *IR-$10*
  • OS: Windows 8 Pro x64 (It did this with Windows 7 x64 Home Premium too, but I though it was because of the RAM limit)
  • Graphics Card: EVGA GTX-680

Wath the task manager says:

  • Memory: 16.0 GB DDR3
  • Speed: 1600 MHz
  • Form factor: DIMM
  • Hardware reserved: 4.1 GB
  • Committed: 2.7/11.9 GB

What my motherboard says:

  • Memory: 12*** MB
  • Speed: DDR-1600 (Tried 1333 too)
  • Says that the 4 DIMM are filled with 4GB RAM each

What CPU-Z says:

  • Size: 16*** MB
  • Channels #: Dual
  • NB Frequency: 220*.* MHz
  • DRAM Frequency: 802.7 MHz
  • FSB:DRAM: 1:4
  • CAS# Latency (CL): 9.0 clocks
  • RAS# to CAS# Delay (tRCD): 9 clocks
  • RAS# Precharge (tRP): 9 clocks
  • Cycle Time (tRAS): 24 clocks
  • Bank Cycle Time (tRC): 46 clocks
  • It also detects all 4 slots of RAM correctly with the correct informations

Memtest86+

  • Reported only 12 GB of RAM

What I tried:

  • Disabling the "Maximum memory" option in msconfig (It was disabled by default)
  • Enabling the "Memory remapping" option in the UEFI/BIOS settings (It was on by default)
  • Updating my BIOS firmware

What would cause such amount of RAM to be Hardware reserved?

share|improve this question

marked as duplicate by KronoS, DragonLord, Brad Patton, Dave M, Scott Apr 16 '13 at 0:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
The frequency of the memory that CPU-Z detects doesn't match what task manager detects. Its safe to say that CPU-Z is wrong in a case like this. Besides your missing memory is being reserved by hardware. –  Ramhound Apr 15 '13 at 16:57
    
@KronoS My problem didn't seem to be exactly the same as this one. –  Manhim Apr 15 '13 at 20:23
    
The solutions are so close to each other, the two question should be merged IMO. We'll see what other community members think. –  KronoS Apr 15 '13 at 21:34
    
The solution to the other question was a motherboard config, while this was a memory stick not fitted in completely. One's an honest mistake, the other is a stupid mistake :P . –  Manhim Apr 15 '13 at 21:49

2 Answers 2

up vote 4 down vote accepted

This is almost always caused by an improperly seated CPU or a damaged CPU socket. Another possibility is a damaged or contaminated RAM socket. The giveaway is that precisely one stick of memory is missing.

To confirm this diagnosis, try removing both sticks from one channel. Then try removing both sticks from the other channel. If one channel recognizes the full memory and the other doesn't, check the other set of RAM in the bad channel to confirm that it is the channel and not the RAM sticks.

If you confirm the diagnosis, check the RAM sockets on the problem channel carefully. Make sure no dirt or other contamination is evident in the RAM sockets.

If that doesn't resolve the problem, take the heat sink off the CPU and then remove the CPU from the socket. Inspect the CPU's bottom for cleanliness. Check the socket for any damaged pins. By extremely careful. If possible, clean the old heat sink compound off the CPU and heat sink. Fix any problems you find, reseat the CPU, put new heat sink compound on the CPU and heat sink, and mate the CPU to the heat sink.

If that doesn't solve the problem, a damaged CPU, motherboard, or RAM socket is likely.

share|improve this answer
1  
I removed the fourth RAM stick from my board and it still detected the same amount of RAM (12GB). I checked and I saw nothing wrong, so I put it back and from that time it got well detected. Seems like simply pushing on the RAM isn't enough to check if it's fully in the socket, it's better to remove and put the RAM back in. –  Manhim Apr 15 '13 at 21:03

Your video card may be using part of the physical address space in order to facilitate access to video memory. This is called the PCI hole.

Basically, what's happening is that the video card's own memory (which is assumed to be 4 GB of GDDR5) is being mapped to the physical memory address space, taking up space that could otherwise be used for RAM. This does not mean that the video card is actually using 4 GB of RAM on your motherboard. It means that the system is using 4 GB's worth of memory addresses to address the video card's memory, rather than your computer's RAM.

Check your BIOS settings to determine whether you can remap this memory. Otherwise, there's probably no workaround for this behavior.

You might want to read my answer here as well.


If your video card has 2 GB of memory and not 4, there may be a technical restriction imposed by the motherboard. Make sure your settings are correct.

share|improve this answer
    
If that's the case, would I still miss that 4GB of RAM as told from my motherboard? or would it happen only in the OS? –  Manhim Apr 15 '13 at 20:21
    
Also, my graphics card have 2GB of RAM, not 4. –  Manhim Apr 15 '13 at 20:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.