Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have tried to run several different windows commands and most of them return an error message. i first ran taskkill, then tasklist, and then systeminfo and none seemed to work.

C:\>tasklist
ERROR: The specified module could not be found.

I tried running command prompt as administrator and i tried using the full location c:\windows\system32\tasklist and all return the same error The specified module could not be found. I navigated to the system32 folder and was able to locate the exe. this commands exists and when i run HELP from command prompt it gives the command and its short description. but trying to run them returns an error message. i looked around online and couldn't seem to find anything specifically identifying a solution to this problem.

operating system is windows 2003

share|improve this question
    
What version of windows? You may also want to update the question with the value of your PATH environment variable the you see in the actual console where you have the issue. –  EBGreen Apr 15 '13 at 18:31
    
windows server 2003 –  David Shears Apr 15 '13 at 18:38
    
What is the value of the PATH variable? –  EBGreen Apr 15 '13 at 19:01
    
%systemroot%\system32 –  David Shears Apr 15 '13 at 19:12
    
That is the only thing in PATH? I would think that you would have more issues than this then. Also, are you getting the PATH variable in the actual console? Or are you looking at it in machine properties? Also, what is the value of SYSTEMROOT? –  EBGreen Apr 15 '13 at 19:15

2 Answers 2

Sounds like some Windows DLLs are corrupted. Try running system file checker (sfc.exe) and see whether it finds anything missing. Also might be caused by some viruses or malware.

share|improve this answer
    
i will run sfc and see if this solves the problem. this past weekend ran some virus scans and malwarebytes and removed alot of hazardous stuff from the system. restarted last night and now this morning this problem exists. could be related. –  David Shears Apr 15 '13 at 19:14
    
ran sfc and still having the problem –  David Shears Apr 19 '13 at 1:39
up vote 0 down vote accepted

Change the registry value:

hklm/software/microsoft/windows nt/winlogon/sfcdisable

to 4 from 0 and run sfc /scannow and the problem should be fixed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.