Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to get to work new feature of nvidia drivers (319.12) and randr 1.4 - offloading.
This is laptop with GT540M and wired like this:

  • intel: LVDS1,HDMI1
  • nvidia: VGA1

New feature described in article (manual) bellow should work like this:

  1. Everything is rendered in nvidia graphics (not just opengl, like in bumblebee)
  2. GC is offloaded to sink, intel card and from there to external monitor (panel or hdmi1)

I followed manpage, but i'm stuck at step 2, nvidia seems to be rendering xserver but offloading isn't working (it seems to by trying to display it at vga1). See xorg.0.log (second link)

http://us.download.nvidia.com/XFree86/Linux-x86/319.12/README/randr14.html
http://pastebin.com/TJqK2GKG

Has anyone managed to get this to work?? If so, what am I doing wrong? Thanks in advance.

Note: This has nothing to do with Bumblebee, please do not tell me to just use it.

EDIT: I tried to list providers in .xinitr, It seems that intel isn't listed as provider. Prolly has something to do with modesetting.

share|improve this question
    
All I get is 'blank screen', others report same issue here: <br> devtalk.nvidia.com/default/topic/539322/… –  AoeAoe Apr 15 '13 at 22:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.