Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows server 2k3 installed on the web server. I have it configured to listen to traffic on port 80.

I am running a simple website using the XAMPP stack. Again, have this configured to listen for traffic on port 80.

I am using the free DNS service no-ip.org, with the client on the web server. I have that configured to redirect port 80 to port 8080 because Cox Communications blocks port 80.

I have set static internal IPs assigned to the server and port forwarding for port 8080 to the servers internal IP and port 80.

When Im inside my home network, type the URL, the website loads and operates fine. Any traffic outside the network typing in the URL gets unable to load page.

Am I missing anything else that is preventing traffic from reaching the server?

Also, I should explain how my network is wired..and will make changes if needed:

|MODEM| --> |WIRED ROUTER| --> |WIRELESS ROUTER|

        /         \    
     |SWITCH|    |MAIN DESKTOP|
      /    \

|WEB SERVER| |FILE SERVER|

share|improve this question

migrated from serverfault.com Apr 16 '13 at 0:01

This question came from our site for professional system and network administrators.

    
could you try forwarding to the same port instead of 8080-80 try 8080-8080 –  CSharp Student Apr 15 '13 at 23:12
    
That busted it. So once I changed everything to use all 8080, including configuring the port forwarding and port Apache listens on, everything broke. I wonder if its something else with the Apache config? –  Dominick Intorre Apr 16 '13 at 1:14
    
using cmd and netstat -abt | more do you see the port 8080 between there? Did you change listening port in c:\yourxampmap\...\httpd.conf Is it possible your isp is blocking that port? –  CSharp Student Apr 16 '13 at 5:00

2 Answers 2

It sounds to me that either your modem or wired router is blocking the forward. Make sure all of the devices are correctly forwarding.

share|improve this answer
    
Sorry its been a while since Ive updated this. OK, as for the firewall issue, I have checked and rechecked, and as far as I can tell, Windows Server 2K3 by default has the firewall off (at least I turned it off) and also created exceptions for ports 80 and 8080 to allow them through. As for the modem and/or router blocking the forward...that is a maybe. However, I used the canyouseeme.org service, and with the server can punch in port 8080 and confirms it can see it open. So I just dont know. –  Dominick Intorre Apr 19 '13 at 19:20
    
Even though the port shows open it still may not be forwarding correctly or at all. I would first verify my switch and modem are both allowing the traffic then move to the server. What you could try is to hook the file server up directly into the modem and get it working through it first. Then move it to the wired router and see if it works then. Just use a baby step process. –  Travis Apr 22 '13 at 12:27

There is actually an Inbound Rule .. World Wide Web Services (HTTP Traffic-In) in Windows Firewall that you need to enable in order to make it work. But this predefined rule is specifically designed for Windows Vista and IIS and Port 80.

screenshot of rule

May be you need to do something similar in Windows Server 2003. Did you try to disable your firewall in both Windows and Router ?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.