Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using KRFB as remote desktop server in my Linux Mint KDE. It works fine as usual remote desktop server but I've to log-in then run it manually (or at start up)

How can I run KRFB of any remoter desktop server runs as daemon without need to log-in at first?

share|improve this question
add comment

3 Answers

What you can do is to start a ssh session and run krfb:

local> $ ssh usuario equiporemoto usuario@equiporemoto > $ krfb --display :0 &

share|improve this answer
add comment

If you want to start a remote server that doesn't depend on the X-Server being started, you can add su username -c remoteserver & to /etc/rc.local. As KRFB depends on KDE or at least an X-Server running (didn't go to deep into it), you have to do a login on your machine.

The solution is enabling autologin for KDE and putting the remote server into KDEs autostart. As I'm not into KDE, I can't exactly tell you how you enable autologin and how autostart applications are set in KDE, but it shouldn't be much of a problem.

share|improve this answer
add comment
up vote 0 down vote accepted

I found the solution during my research in KDE system settings.

https://forum.kde.org/viewtopic.php?f=18&t=110847

KDE system settings offers that option (Lock Session)... voila.

See this screenshot: Login Screen - System Settings

share|improve this answer
    
Link only answers are discouraged here. Please summarize what is on that page, then cite the source here –  Canadian Luke Apr 21 '13 at 2:36
    
I modified the answer. –  mbnoimi Apr 21 '13 at 13:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.