Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I admin a website for a student group here at my university, and I usually edit either with Dreamweaver (not in WYSIWYG mode, mind you) or by ssh-ing into the server and editing via nano. Just today, a problem started that I've never encountered before: when I edit a page (any page, and any kind of edit), my computer (running OS X 10.8, latest version) takes between 10 and 20 minutes to display the results of the edit.

I've tried every obvious thing I could think of: I cleared my (client-side) cache, which was no help. I've confirmed that this problem is either specific to OS X or specific to my particular machine — I've tried multiple browsers on this computer, getting the same problem each time, and I've tried using another (Windows) computer, which displayed the results of my edits immediately.

I don't have any idea what could be causing this — some caching problem, maybe? I also don't get why this problem appears to be restricted to this particular site that I admin — that is, it doesn't take 20 minutes for me to receive a new email, or to see a new update on Facebook, for instance.

EDIT: For what it's worth, the Windows computer is connected via ethernet, while the Mac is connected via WiFi. Both are connected to the same network though, and I don't know how that could make a difference.

share|improve this question

migrated from webmasters.stackexchange.com Apr 16 '13 at 11:42

This question came from our site for pro webmasters.

1  
Have you tried a different (OS X or non-OS X) machine on wi-fi? What happened? –  GDav Apr 16 '13 at 7:43
    
Not sure this belongs here. (If the Windows machine show the edit immediately, then the problem isn't the site, which is this SE site's concern.) But I'm also not entirely sure where it should go. SuperUser, maybe? –  Su' Apr 16 '13 at 8:03
    
Try a Command+Shift+R on the page. Additionally check your expires on HTML/PHP. –  bybe Apr 16 '13 at 9:29
    
GDav — it works fine on my smartphone (Galaxy Nexus, on WiFi) Su — Thanks for the tip. Looks like it's been migrated. bybe — I have tried cmd+shift+R. And what do you mean "check your expires?" –  Jake Apr 16 '13 at 14:41

1 Answer 1

up vote 0 down vote accepted

Universities tend to have quite aggressive caching – like this sort of thing – so it seems likely that that's the problem. Quite why it's different for wi-fi than ethernet I don't know.

There are various ways around this. In fact, it's a common problem even without a university's in-house cache, as a lot of sites are deliberately configured to be cached for a long time in order to enhance load speed.

One way they get around the problem of updated files is "versioning" - that is, append a version number to the file name. If the file name's changed, then all users will get the new, updated file and not the old cached one.

If that sounds a bit bewildering, take a look at HTML5 Boilerplate. Amongst much else, it contains all the information you need to implement versioning in a relatively painless way.

For the actual web pages themselves, it's more complex since you obviously don't want to keep changing their names. You can force these not to be cached, but it's probably better to just work from the connection that isn't suffering with the problem.

In any case, you'll find a wealth of info on caching, versioning, forcing things not to cache and so on here.

share|improve this answer
    
Thanks! I'd upvote you if I could. (Not enough "reputation" yet.) For some reason the issue appears to have solved itself, though. –  Jake Apr 16 '13 at 21:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.