Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The problem is that it keeps looping. It gives me that error, then it tries to access it again, then again, then again, then again etc.

And I can't seem to find an answer on the internet about it. At least Google doesn't return any errors.

I get the following:

error '/dev/mapper/arch_root-image' device did not show up after 30 seconds

The laptop on which I'm running the installer is a Dell Vostro 1500 (quite old). Pretty sure it doesn't have a 64bit architecture so I booted in the i686 installer mode, instead of x86_64 mode.

I find that if I do it in the x86_64 mode I don't have these errors, it just works, until you get to installing drivers and stuff, at which point it doesn't go very well.

This is my first time installing Arch Linux, so any help to a newbie is very appreciated. :)

EDIT 1:
No particular output from mount, I just run the following commands in this order after partitioning the hard drive correctly:

mkswap /dev/sda2
swapon /dev/sda2
swapon /dev/sda2 # confirms it has been set
mkfs.ext4 -E discard /dev/sda1 # boot partition
mkfs.ext4 -E discard /dev/sda3 # root partition
mount /dev/sda3 /mnt # no output
mkdir /mnt/boot
mount /dev/sda1 /mnt/boot # no output

When I run ping 8.8.8.8 I get connect: Network is unreachable.

Then I run pacstrap /mnt base which returns tons of errors, no text progress bar on the right at all and a last error which is:

==> ERROR: Failed to install packages to new root

EDIT 2:
Running lspci | grep -i net I get 2 results:

03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
0c:00.0 Network controller: Broadcom Corporation BCM 4312 802.11b/g LP-PHY (rev 01)

Running lsusb I get 12 results. Only 2 related to network stuff:

Bus 003 Device 002: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 003 Device 003: ID 413c:8126 Dell Computer Corp. Wireless 355 Bluetooth
share|improve this question
    
The laptop seems to have a Core2Duo CPU, which supports 64bit, so you should be running the x86_64 installer. If you would clarify the part about "until you get to installing drivers and stuff, at which point it doesn't go very well", you could actually get a good answer. –  Stefan Seidel Apr 16 '13 at 14:04
    
@StefanSeidel Oh I see. Thanks for clarifying. I mean when it gets to running pacstrap /mnt base, at that point it does not install anything at all. I'm watching this video for reference, and this is the minute I'm in youtu.be/kQFzVG4wZEg?t=11m32s –  Greduan Apr 16 '13 at 14:10
    
I strongly suggest to follow the official guide from the ArchWiki. Can you add the output of mount just before you run pacstrap? Have you verified that you can ping 8.8.8.8? –  Stefan Seidel Apr 16 '13 at 14:15
    
@StefanSeidel I added the info to the question. –  Greduan Apr 16 '13 at 14:23
    
Well, obviously you have no network access, so you need to fix this using wifi-menu or just plug in a network cable. –  Stefan Seidel Apr 16 '13 at 14:50
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.