Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do you get rvm to play properly with gnome-terminal?

wim@wim-desktop:~$ rvm list

rvm rubies

=* ruby-1.9.3-p392 [ x86_64 ]
   ruby-2.0.0-p0 [ x86_64 ]

# => - current
# =* - current && default
#  * - default

wim@wim-desktop:~$ ruby --version
ruby 1.8.7 (2011-06-30 patchlevel 352) [x86_64-linux]
wim@wim-desktop:~$ rvm use 1.9.3

RVM is not a function, selecting rubies with 'rvm use ...' will not work.

You need to change your terminal emulator preferences to allow login shell.
Sometimes it is required to use `/bin/bash --login` as the command.
Please visit https://rvm.io/integration/gnome-terminal/ for a example.

I read here that I just need to check "Run command as a login shell" in my gnome-terminal profile preferences, which I did and reopened a new terminal but it didn't work. Then I read here that to fix the configuration files automatically I can run:

wim@wim-desktop:~$ rvm get [head|stable] --auto
stable]: command not found
cat: /home/wim/.rvm/help/get: No such file or directory
Could not update RVM, get some help at #rvm IRC channel at freenode servers.

Which didn't work either, as you can see.

I'm on Ubuntu 12.04 and the ruby-rvm package in the repositiories is also too old and broken, apparently.

Coming from python background, where I have 2.7 and 3.2 happily coexisting and I've yet to see pip fail, the whole world of ruby versioning and packaging seems to be a bit of a dogs breakfast. Which is a shame because I find the language otherwise very modern and powerful!

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

I think I fixed it by putting in my ~/.bashrc file:

PATH=$PATH:$HOME/.rvm/bin # Add RVM to PATH for scripting
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.