Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a MacBook Pro running Windows 7 32 Bit (under BootCamp). It is a 4G machine, and has happily been running for 2 years with 3.5 or so usable RAM. I started noticing the fan and hard drive working harder the last couple days, and today noticed that the usable RAM is now only 2.1G.

I looked at the Resources by Connection memory map in Device Manager, and see that 1.8 GB is being assigned to the GForce 330M card (address 90000000-FEAFFFFF). I can only assume that this was not true before, and was, at the very least, substantially less, since I had 3.5 available.

My question is, how can I tell the GForce to stick to a smaller memory footprint? Since I am on a MacBook, I don't think there is any way to disable/restrict it in the "BIOS", as recommended on some sites. Obviously something was able to enable it to request more RAM. (It may have happened after I got a message from windows last week asking if I wanted to disable Aero because I was getting low on memory -- I was running a lot of Visual Studios at once -- and I said yes, then finished what I was doing and rebooted. But I am not sure if that was when it changed.)

share|improve this question
    
What do you mean when you say the usable RAM? How are you getting that figure? –  ernie Apr 16 '13 at 18:14
    
Control Panel/System. Under Installed memory (RAM) it says, "4.00 GB (2.18 GB Usable)". I know why it is that low (graphics card reserved memory), but not how it suddenly changed, or how I can change it back. –  user1689571 Apr 16 '13 at 19:09
add comment

1 Answer

Install the 64Bit Windows 7 or use a PAE Patch with implements this hack.

share|improve this answer
    
Thanks. I am not quite ready to patch my OS. My question was more related to getting it back to the state that it was in last week. –  user1689571 Apr 17 '13 at 12:37
    
use system restore? Maybe an update (which patches the kernel) changed it. –  magicandre1981 Apr 17 '13 at 17:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.