Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Our embedded QuickTime movies are not playing in Safari under Snow Leopard.
They play fine using Firefox on the same Mac, and play fine on PC's.

Movie sizes are usually around 200MB. Smaller (50MB) videos seem to work fine.

I've tried tons of different variations of embedded code, from straight <object>..<param>..<embed> tags to the QT_WriteOBJECT() javascript function in AC_QuickTime.js

When I watch the QuickTime cache folder, the temporary file stops downloading after about 1 or 2 MB. But, once it caches that little bit, you can usually hit refresh, and it will start playing.

We have 6MB DSL, I'm using Safari 4.0.3 (6531.9) and QuickTime 10.0 (51)

Here is a sample: http://www.thelifechurch.com/test.htm

share|improve this question
add comment

3 Answers

Well I've found a temporary work-around by looking at the Apple trailer site. It appears that they use a poster video before they launch the big video.

I added a simple poster video that says "loading video..." and set it's autohref to true. That way you dont actually have to click the poster video, it will go to the real video automatically. Here's my code so far:

<script language="JavaScript" type="text/javascript">
   QT_WriteOBJECT('http://www.thelifechurch.com/media/play.mov', '640', '376', '',
    	 'href','http://www.thelifechurchtv.com/media/072708tv.mov',
    	 'target','myself',
    	 'autohref','true',
    	 'autoplay','true',
    	 'scale','tofit',
    	 'controller','true',
    	 'bgcolor','black');
</script>
share|improve this answer
add comment

Well for starters the start.html shows these errors:

test.htm:7<script> is not allowed inside <html>. Moving <script> into the <head>.
test.htm:12<object> is not allowed inside <html>. Content ignored.
test.htm:12<param> is not allowed inside <body>. Content ignored.
test.htm:12Unmatched </embed> encountered.  Ignoring tag.

(You're missing the <body> tags in the test document which isn't helping much).

Fixing that mistake got it working fine for me.

share|improve this answer
    
It was just a quick test page, but the real page had all of the appropriate headers, and body tags. I just added those to the test page, and still not working. Are you using QT in Safari under Snow Leopard? –  user14851 Oct 21 '09 at 19:10
    
@peteshack: I am. Of note, the video would load using the QT7 controls for me however. –  Chealion Oct 21 '09 at 20:00
add comment

Yes, this doesn't work for me either. I tried getting the movie directly at http://www.thelifechurchtv.com/media/072708tv.mov, and that worked.

I also tried making a local file without the bulky javascript:

<html><head><title>required</title></head><body><embed
  src="http://www.thelifechurchtv.com/media/072708tv.mov"
  width="640" height="376"
  pluginspage="http://www.apple.com/quicktime/download/"
  scale="1" controller="true" bgcolor="black">
</body></html>

Which did not work.

BTW: This "inspired and practical message" for the people living "without purpose" makes me sad.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.