Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've experienced some problems with the booting of my laptop and I'm now unable to boot from the harddisk. In particular when booting I get this error message:

No bootable device -- insert boot disk and press any key

How can I check whether my harddisk is completely broken(and thus should be replaced) or if there is some "software" problem preventing the boot?

Note that booting from a Live USB I can see the partitions on the disk via:

sudo fdisk -l

Which make me think that the harddisk is not completely broken.

I must also mention that some times(seldomly) I could see some I/O disk errors when running Linux, and this make me think that, probably, the harddisk has always been a bit "damaged"


This is the full story of what happened and what I did:

I have an Acer Aspire 5742G which had installed Kubuntu 12.04.2 and Windows7 in dualboot. The windows installation often gave problems. About 80% of the times I booted windows the computer, on subsequent boots, would simply keep rebooting(something really similar to this question).

Yesterday I booted on windows and the computer started rebooting. After a forced shutdown the laptop started showing this error message:

No bootable device -- insert boot disk and press any key

I tried to recover grub multiple times, I also reinstalled kubuntu, finally I wiped all the previous installations and installed kubuntu on the whole disk, but nothing changed.

I then tried to recover the windows installation using the recovery disks, but right after starting the recovery I got this error message:

Restore Failed--Error code 0x3ed (The volume does not contain a recognized file system. Please make sure that all required file system
drivers are loaded and that the volume is not corrupted.) 

Searching on the net I found this post about the error and after doing:

sudo dd if=/dev/zero of=/dev/sda bs=512 count=1

To wipe the MBR I was able to complete the recovery process.... to absolutely no results. When I boot I still get the No bootable device ... error.

share|improve this question
    
What kind of recovery disks are you using? Does it boot with BIOS/MBR or UEFI? BTW, if the hard disk have nothing important left, I would try to re-initializing the partition table. –  Alvin Wong Apr 17 '13 at 8:25
    
@AlvinWong It uses BIOS/MBR. The recovery disks where the ones I created right after installation(I don't rememeber if it was through an Acer program or if from Windows 7 utilities...). I was able to save all important information of the hard disk and I already removed/recreated/formatted the partitions multiple times. –  Bakuriu Apr 17 '13 at 9:56

1 Answer 1

up vote 1 down vote accepted

The smartctl utility from smartmontools can help you to check and test your hard drive.

You can check your hard drive SMART values using:

# smartctl -A /dev/sda

or

# smartctl -a /dev/sda

But more importantly, you can test your hard drive using:

# smartctl -t [short,long] /dev/sda

And check the results:

# smartctl -l selftest /dev/sda

You can also use the badblocks utility but be careful as you can easily wipe all your data from the drive.

share|improve this answer
    
The first command shows a table where I can see that attribute Reallocated_Sector_Ct is FAILING_NOW. Also the short test reports a status of Completed: unknown failure. I've just launched the long test to see a more verbose explanation, even though I guess the only option is to replace the HD... –  Bakuriu Apr 17 '13 at 16:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.