Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been trying several desktop environments and window managers, and I think for now I'm gonna stick with E17.

However, I can't seem to uninstall Xfce 4 which I installed earlier when experimenting.

I try running sudo pacman -Rs xfce4 in order to delete Xfce and all it's dependencies that other apps don't need.

This is the output that command produces:

checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: libxfce4ui: requires xfconf

Which to me doesn't make any sense, perhaps it's obvious though. So why can't I uninstall this dependency? From what I understand, it can't uninstall it because another package (which is also going to be deleted) needs it, so it doesn't delete it and throws me this error...

If my theory of what happening is correct, how can I go about making it not check for dependencies. If I'm wrong, which I probably am, how could I go about solving this error?

share|improve this question
    
Could you check if a system update sudo pacman -Syu produces the same error? –  Nicolas Apr 17 '13 at 21:17
    
@Nicolas It does not output that error. I did download some updates. Thanks for reminding me. :) –  Greduan Apr 17 '13 at 21:54

2 Answers 2

You can try

pacman -Rsc xfce4

From the Wiki:

To remove a package, its dependencies and all the packages that depend on the target package.

share|improve this answer
    
I did consider that... However how about the case when I have another package I do want, which depends on one of these... And since I'm still a newbie I haven't paid that much attention to my packages yet... –  Greduan Apr 18 '13 at 15:15
    
Well in that case you can't uninstall the original package, clearly because if others which you want depend on it, it can't be uninstalled. –  Stefan Seidel Apr 18 '13 at 15:22
1  
That's what sudo pacman -Rs xfce4 however. From the wiki: "To remove a package and its dependencies which are not required by any other installed package". Basically it removes anything I'm not actually using, which works better for my needs. My question is why I'm getting this error though... –  Greduan Apr 18 '13 at 16:01

xfce4 is not a package but a group of package.
So, may be when you try to remove xfce4, pacman tries to remove each package from the xfce4 group and mix up itself with the dependencies.
I suggest you to run again the command to install xfce and to type enter to install all the packages of the xfce4 group

sudo pacman -S xfce4

Then after that try to uninstall xfce as you used to do

sudo pacman -Rs xfce4

If the problem persists, try to uninstall manually the packages of the xfce4 group

sudo pacman -Rs xfdesktop

Repeat the same command for the remaining packages :

   1) exo  2) garcon  3) gtk2-xfce-engine  4) gtk3-xfce-engine  5) thunar  6) thunar-volman  7) tumbler  8) xfce4-appfinder
   9) xfce4-mixer  10) xfce4-panel  11) xfce4-power-manager  12) xfce4-session  13) xfce4-settings  14) xfce4-terminal
   15) xfconf  16) xfdesktop  17) xfwm4  18) xfwm4-themes
share|improve this answer
    
That works... Still had to remove xfconf from the list because it kept giving me the error. But at least now they're gone. :) –  Greduan Apr 18 '13 at 22:07
    
@Eduan, the first solution worked or you needed to use the second one? Do you still have the same problem with the xfconf package? Is your problem solved? –  Nicolas Apr 19 '13 at 17:11
    
I had to uninstall manually all the packages of the xfce4 group. Except those that I needed. :) –  Greduan Apr 19 '13 at 17:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.