Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I click a link in IE9/IE10 and nothing appears to happen. I notice that the tab icon updates and spins as well as the tab text says the usual things. I open Fiddler and click another link. Everything loads. Weird. I happened to scroll my mouse wheel for no reason and the page magically appeared.

This problem is very intermittent for me. Sometimes closing/opening IE9/IE10 fixes it, sometimes not.

Maybe the VirtualBox video driver has something to do with it?

EDIT -- More Information

  • Dell Inspiron N7110 laptop
  • VirtualBox 4.2.6
  • Host: Win8 Pro 64bit
  • Guest: Win7 Pro SP1 32bit

I'm going to try upgrading VirtualBox to the newest version (4.2.12).

share|improve this question

1 Answer 1

Exactly the same issue here, so I uninstalled Internet Explorer 10. The same problem appeared in Internet Explorer 9, so had to go back all the way to IE8 to get it working properly. After upgrading to IE9 again, the issue is back.

I suspect it has something to do with DirectX hardware acceleration which was introduced in IE10, and is reported to be an issue on hybrid graphics cards. My laptop has a nVidia Optimus graphics card, running Ubuntu 12.04 with a Windows 7 guest. I tried to turn off hardware accelerated graphics rendering in IE10, but to no avail.

Try enabling 2D or 3D acceleration on the virtual machine. That seemed to fix it in IE9. IE10 has to wait for me because of other issues, but I suspect this might work there also.

share|improve this answer
    
I did read about that issue with IE10. Unfortunately I've had 2D and 3D acceleration enabled already. Also, a co-worker confirmed that he had this problem in IE9 as well. –  Derek Smith Apr 19 '13 at 18:19
    
Yes indeed. After some more testing it came back in IE9 again. I ended up upgrading to IE10 (again), turned on hardware acceleration in IE, and now it's working fine. This is really weird :/ –  Audun Wangen Apr 25 '13 at 7:00
    
I had to enable 2D accelleration, which fixed this issue on IE 11. –  bouke Jan 6 at 13:09
    
Enabling 2D acceleration fixed this for me (OS X 10.9 host, Win 7 + IE 11 guest). It also fixed a lot of sluggishness with IE's developer tools. –  kwoodfriend May 15 at 15:37
    
My problem was that the video memory was set too low, and I had to enable 2D acceleration. –  hcharge Jul 17 at 12:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.