Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A few weeks ago, I ran quite a few of the commands found at https://github.com/mathiasbynens/dotfiles/blob/master/.osx hoping to get rid of a few of the annoyances on my Mac. Unfortunately, in the process, I must have accidentally configured Finder to open a new window whenever Time Machine runs a backup to the network drive1, and I can't figure out how to put the setting back.

Three of the commands were supposed to make Finder automatically open a new window when a new drive is mounted, so I think this might be what caused the problem:

# Automatically open a new Finder window when a volume is mounted
defaults write com.apple.frameworks.diskimages auto-open-ro-root -bool true
defaults write com.apple.frameworks.diskimages auto-open-rw-root -bool true
defaults write com.apple.finder OpenWindowForNewRemovableDisk -bool true

I've tried reversing the commands by setting the values back to false:

defaults write com.apple.frameworks.diskimages auto-open-ro-root -bool false
defaults write com.apple.frameworks.diskimages auto-open-rw-root -bool false
defaults write com.apple.finder OpenWindowForNewRemovableDisk -bool false

I've also tried deleting the entries like this:

defaults delete com.apple.frameworks.diskimages auto-open-ro-root -bool false
defaults delete com.apple.frameworks.diskimages auto-open-rw-root -bool false
defaults delete com.apple.finder OpenWindowForNewRemovableDisk -bool false

Neither of those have worked. Even after restarting the computer, a new finder opens to the Time Machine drive whenever Time Machine runs a backup.

What can I do to stop Time Machine from opening a Finder window every time it runs?



1 Time Machine is backing up to a Time Machine enabled ReadyNAS network drive.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

This drove me nuts as well! After trying the same reversal commands without success, I started poking around with defaults read (rather than write) and saw the difference between:

$ defaults read com.apple.frameworks.diskimages
{
    "auto-open-ro-root" = 0;
    "auto-open-rw-root" = 0;
}

and:

$ sudo defaults read com.apple.frameworks.diskimages
Password: ...
{
    "auto-open-ro-root" = 1;
    "auto-open-rw-root" = 1;
}

Therefore I had to sudo to properly flip the switch:

sudo defaults write com.apple.frameworks.diskimages auto-open-rw-root -bool false

Verify the change with:

$ sudo defaults read com.apple.frameworks.diskimages
Password: ...
{
    "auto-open-ro-root" = 1;
    "auto-open-rw-root" = 0;
}

Time Machine should no longer open a new Finder window every time a backup starts, now that we've affected the setting in the 'root' domain (to borrow Apple's terminology) it runs in, rather than your normal user's. Note that I did not need to log out or reboot for the change to take effect (Mountain Lion 10.8.3).

I left read-only disk images to open automatically since that hasn't bothered me.

You should now be able to climb down from the roof, though you (like me) may still be sore from kicking yourself. ;)

share|improve this answer
    
Thanks so much! I ran the command with sudo, and now the window isn't opening every time Time Machine runs. Thanks! –  Joshua Dwire Apr 22 '13 at 11:53
    
Glad it worked! There are some nice tweaks in that script, and some questionable ones as well... Probably best to fork it on GitHub and customize that for future use. –  Brandon Jones Apr 22 '13 at 17:16
    
Had the same issue, this solved it. +1 –  padde Aug 25 '13 at 20:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.