Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm a student at Penn State, and for my engineering class I use a program called SolidWorks. Penn state provides me with a fully licensed edition of this program, but for it to acquire a license I need to connect to the PSU VPN.

I've installed a program that they provided that signs me into the VPN using my student ID. The program is called Juniper Networks Network Connect 6.5.0.

This program does not automatically sign me in, nor does it automatically run at the startup of windows (I am running windows 8 64 bit). However, after installing this program my internet has been extremely slow. It's slow no matter what, I can re-start my computer, disable and re-enable my NIC, throw my computer on the ground and pick it up, it doesn't matter what I do now, my internet is slow.

I had the VPN client installed once before, and uninstalled it thinking that I only needed it to install solidworks, and not knowing that I would need to sign into the VPN every time I wanted to use solidworks. I never noticed that my internet was slower that time, and solidworks downloaded through the VPN I believe and it was extremely fast. Once it was installed I uninstalled the VPN and never noticed a change in internet speed, but now that it is installed and only running when solidworks is, my internet is just dreadfully slow, even for things like online tests where it's only loading text.

Why would this program slow down my internet just by being installed on my computer? Could it have changed some network setting that is routing all traffic through the VPN even when I'm not signed in and the program isn't even running? What on earth could I do to fix this?

Any help would be much appreciated!!

-Derek

EDIT: I may have fixed this problem, the Juniper client that connects me to VPN runs a service that starts at startup. I've set the service to manual and re-started my computer and the internet seems much quicker!

There is still a small problem though. This service is called dsNcService and now that I've set it to manual, it dissapeared from the list in services (in administrative tools in control panel). Now that it's gone and has been set to manual, the client won't launch, it gives me an error that says I need to re-install it. However, if I go into services and click on the juniper client itself (which is still there, only dsNcService dissapeared) and click on start, it will start up like it did before I set dsNcService to manual, but I think that's pretty weird.

share|improve this question
    
I have a (probably) stupid question: Have you tried a different internet connection/hotspot? Could the one you're using suddenly have become slow at the same time you installed the VPN? –  Joshua Dwire Apr 17 '13 at 20:30
    
I don't think so, it's my connection in my room, it's been fast all year, but maybe I should try wifi somewhere. –  Derek Apr 17 '13 at 20:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.