Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Not sure if this is the right place - please refer me to another group if not.

I have an issue getting my Asus laptop (Windows 7) LAN card to work. My setup is: dsl modem --> asus wireless router --> various devices.

The wireless works fine on this machine. When I plug a cable into it, the network is not recognized. When I plug the same cable into my wife's mac, it works fine.

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix  . :

I've tried uninstalling / reinstalling the NIC. In the network connections, when I right click and run repair, it tells me to plug an ethernet cable into the network adapter "Local Area Connection".

EDIT: The connection will work when plugged directly into the modem.

Thanks for your help.

share|improve this question
    
Are you using a crossover cable? –  lopsided98 Apr 17 '13 at 21:29
    
just a regular CAT-5E patch –  jabs Apr 17 '13 at 21:35
    
You should try replacing it anyway to help diagnose the problem. –  lopsided98 Apr 17 '13 at 21:38

2 Answers 2

Try using a different ethernet cable that isn't crossover, because if your current one is a crossover, that could be causing your problem. Most ethernet cards have a feature called Auto-MDIX which automatically detects whether or not you are using a crossover cable. While almost all new computers have Auto-MDIX, this could possibly be causing problems if the laptop doesn't support it. Even if the cable is not crossover, replacing it would help to diagnose the problem.

share|improve this answer
    
I replaced the cable but same result. Both cables worked with different computers today. How can I tell if it is a crossover cable? Also, here is an overview of the ethernet adapter. It's only a few years old. –  jabs Apr 18 '13 at 1:17
    
The JMC250 is a single-chip PCI-Express Gigabit Ethernet Controller. The Ethernet function is compliant to IEEE 802.3 Media Access Controller, and IEEE 802.3u 1000BASE-T/100BASE-TX/ 10BASE-T. The MAC supports IPV4, IPV6, TCP, UDP checksum, segmentation task-offload, priority encoding and IEEE802.1Q VLAN features. It also supports Receive Side Scaling (RSS) to balance the loading for multiple CPUs. The Ethernet function supports remote wakeup (including AMD Magic Packet? and Microsoft? Wake-up frame) in both ACPI and APM (Advanced Power Management). –  jabs Apr 18 '13 at 1:18

Have you tried running something like netsh winsock reset? I had a very similar issue (Windows 7, Asus router, cable not detected when plugged), and this command worked for me.

share|improve this answer
    
Unfortunately, it didn't work. Ipconfig shows the same Media Disconnected before and after the command (and restart). –  jabs Apr 24 '13 at 2:42
    
Just to confirm, if you plug the cable from the modem directly into the computer, without the router, does it work? Maybe it's not feasible to try though. –  dhekir Apr 24 '13 at 7:08
    
Yes - it did work! –  jabs Apr 26 '13 at 1:42
    
When you typed the netsh winsock reset, were you using command prompt as administrator? Did you get any error messages? This website may have some information, if it's a Windows-specific error. Some websites also suggest that iTunes or other Apple software might interfere, but in this case it should work at least occasionally... –  dhekir Apr 26 '13 at 7:12
    
Guess what, now I'm having the exact same issue as you do, and netsh winsock reset isn't helping. I can't reboot my machine, so I'll see if I find another solution. –  dhekir Apr 26 '13 at 19:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.