Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to make my WampServer public but nothing i have tried so far seems to be working. It was all good and well before i got a new router from my new provider.

The router is a Huawei HG523a & my ISP is TALKTALK.

These are the settings i have for the port forwarding. Advanced->Advanced->NAT->Port Mapping

Mapping Name: WebServer(HTTP)
Interface: nas_0_38
Protocol: TCP
Remote Host:
External Start Port: 80
External end Port: 80
Internal Port: 80
Internal Host: 192.168.1.2
Enable: Enable

I have reserved the IP address 192.168.1.2 for my computer under Advanced->Basic->LAN->(Ip address Reserve).

I believe this is all i need to do for the router side of things.

Now for Apache: The .httpd file...

Listen 192.168.1.2:80

And that's everything. The problem is that when i put in my public IP address its not forwarding to my WampServer. its just going to the routers log-in page. If i put in my local ip then i get my servers webpage like i should. What am i missing!?

Any help would be great! Thanks,

Chris

share|improve this question
    
Did you check to see that your computer actually has the ip you reserved for it on the router? –  lopsided98 Apr 17 '13 at 21:42
    
yea i used cmd->ipconfig and it was correct –  ChristopherStrydom Apr 17 '13 at 21:46
    
You could try changing your .httpd to just Listen 80 to make it listen on all interfaces. That's really just a stab in the dark though. –  lopsided98 Apr 17 '13 at 21:49
    
Yes no luck there :/ –  ChristopherStrydom Apr 17 '13 at 21:55
    
are there no other settings in the .httpd file that could be stopping it? –  ChristopherStrydom Apr 17 '13 at 21:57
show 12 more comments

1 Answer

up vote 1 down vote accepted

It looks like the Router is the problem here. From what i have read and tested the router does not support NAT Loop back. This means that you can view your server using your public IP address only if you are outside of your own local network I.E (Not connected to your router). The router does support local Loop back which is why you can access the server from your local IP address.

Simply put: You/I need to get a different router which supports NAT Loop Back.

This means that there is nothing wrong with the port forwarding settings shown above.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.