Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is very frustrating.

I have been accessing servername.local on Firefox. That's its URL. No www.

At some time, servername.local ceased to be available and I got an error message: "Server not found". Fair enough.

However, Firefox didn't just try servername.local, it tried www.servername.local as well. "Server not found" again.

The problem is, now that servername.local is back up and running (I can get to it with other browsers and by IP address), Firefox always tries for www.servername.local, no matter if I type in the correct non-WWW URL or use a bookmark.

I cleared the cache, I cleared the history. No change. I flushed the DNS cache, that didn't help either.

Any suggestions?

share|improve this question

3 Answers 3

up vote 10 down vote accepted

Firefox is utilizing Domain guessing. It is an option that will automatically insert www or .com so that you don’t have to.

But, you don’t want that www., and there is a way to shut it off. The option to shut off domain guessing also requires shutting off keyword search for the changes to take place.

Changing Keyword search:

  1. Type about:config in the location bar and hit enter. You will get a message, "This might void your warrantee" pop up. Click the “I’ll be careful, I promise.” button.

aboutconfig

  1. Type Keyword.enabled in the search field and double click the keyword.enabled preference to set the value to false.

aboutconfig1

That is the Keyword Search part taken care of. Now to shutting off domain guessing.

In the search feild type fixup and douoble click on browser.fixup.alternate.enable so that it will go to false.

All done, no more WWW or .com.

fixup

More to be learnerd here: Mozilla Support

share|improve this answer
2  
+1 for the beautiful handwriting! ;) –  MoonSire Nov 13 '13 at 9:53

From http://support.mozilla.org/en-US/questions/714016 and http://support.mozilla.org/en-US/questions/932632 :

  1. In FireFox, go to about:config (this is a special manual configuration page all Mozilla-based browsers have; be careful, as you can really much things up!)
  2. In the Filter box, type in fixup and hit Enter (this will hide all the config elements except those that match this term)
  3. Click on the browser.fixup.alternate.enabled element; you'll see it change from Default to User Set, and from True to False.
  4. Done!

You might also want to check these:

browser.fixup.alternate.prefix - (www.)

browser.fixup.alternate.suffix - (.com)

I have gotten mixed answers when checking these. Some people report it works and some don't. Apparently, these are only added if the URL is unreachable.

share|improve this answer

Include explicitly http://in the address.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.