Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just acquired a Dell Inspiron 7720 with Windows 8 pre installed. I want to remove Windows 8 and install Windows 7 in it. Windows 8 is installed in the C: partition which is in GPT style. There are 2 other partitions that seem to be related to Recovery. I don't care about the data in C: but I don't want to lose what's in Recovery. All partitions are in the same physical disk, which has 1TB of total space.

What I tried to do was to go into BIOS, change boot from UEFI to Legacy and boot from my Windows 7 DVD. The installation process then complained that Windows 7 could not be installed in C: because it is a GPT partition.

In my google searches I learned that Windows 7 can be installed in a GPT partition if I enable UEFI in the BIOS and then boot from the Windows 7 DVD in UEFI mode. However, I have no idea how to boot from the Windows 7 DVD in UEFI mode.

Can anybody advise me on how do acomplish this?

Thanks!

P.S.: I did a search here in superuser before asking, but all I found was a thread teaching how to get to the bios configuration screen. I am able to do that, my problem lies elsewhere.

share|improve this question
    
The recovery partition tends to only contain a backup of windows 8, which can be downloaded from microsoft anytime. Is there a reason you want to keep it? –  Satoh Apr 18 '13 at 0:33
    
I wanted to keep the Recovery so I could reset the notebook to its initial settings in case the installation of Windows 7 went wrong. –  Tavio Apr 18 '13 at 0:47
    
As I saw in the answer comments, you are unable to boot from a dvd? How about USB? You could try launching a partition manager and reformatting C: –  Satoh Apr 18 '13 at 0:52
    
@Satoh: Would you care to enlighten us as to how someone who got Win8 pre-installed on a new PC can download it from MS any time? –  Karan Apr 18 '13 at 21:09

2 Answers 2

up vote 1 down vote accepted

I had the same issue with the Dell 7520 (15R SE)

You need to go to the UEFI with F2 and set the option Load Legacy Option ROM to true.

Now Windows 7 still uses UEFI, but UEFI loads the old VGA BIOS ROM which allows the installation of older Operating systems.

share|improve this answer
    
I didn't get to try this, as I did something different before seeing your answer. I turned on legacy boot in the BIOS and proceeded with the installation of Windows 7. When choosing the drive where I wanted to install Windows, I striked shift+f10 and cleaned my disk in the command prompt. For future reference, the commands I ran were: DISKPART; then LIST DISK; then SELECT x, where x was the number of my drive on the list; then CLEAN. I will however select this answer as the solution, since your problem seems to be very related to mine and you say it solved the problem. Thanks! –  Tavio Apr 18 '13 at 16:32
    
ok, clean removed all partitions and you've now installed Win7 in BIOS mode with MBR partition. But nice to see that it works for you. –  magicandre1981 Apr 18 '13 at 18:32

While I'm not familiar with that particular system and UEFI/BIOS, generally the steps would be:

  • Enable UEFI
  • Disable Secure Boot as Windows 7 does not support it
  • Boot from the DVD - depending on the BIOS, the boot devices may show both legacy and UEFI options in the boot menu; make sure to select the UEFI version if that's the case.
share|improve this answer
    
My problem is exactly in the "boot from dvd part". If I shift+restart windows and choose the boot menu option, I'm presented with a black screen with the options "UEFI Boot" and "Other options". Under the "UEFI Boot" I have 3 selectable options, which are exactly: "Windows Boot Manager", "Windows Boot Manager", "Windows Boot Manager" and then finally "+Network Boot". Choosing any of them won't boot from the dvd. –  Tavio Apr 18 '13 at 0:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.