Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently tried the package manager Homebrew to grab things like PyQt4. It also recommended grabbing Python; no problem, done.

So a simple python at the Terminal window didn't open the recently downloaded instance of Python, so I type brew doctor and it tells me this -

Warning: /usr/bin occurs before /usr/local/bin This means that system-provided programs will be used instead of those provided by Homebrew. The following tools exist at both paths:


Consider amending your PATH so that /usr/local/bin occurs before /usr/bin in your PATH.

Sure, no big deal - I google around and find out about editing .profile to establish paths. I go to my home directory and enter open .profile - it doesn't exist.

No big deal, according to the Internet I can just create one here. So that's fine, touch .profile works. open .profile works. I copy and paste a line from the Internet which puts /usr/local/bin ahead of the rest of the paths. Like so:

export PATH="/usr/local/bin:/usr/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/X11/bin"

Save. Try it. Doesn't work. I remove the double-quotes; no good. I add a colon to the end of the line, for some reason. No good.

I google. I see more information about /etc/paths but even after finding it and entering sudo open paths it seems I cannot unlock it. And besides, most of the Internets also say that just adding a .profile file to my home directory ought to be enough and that I don't need to muck about with this.

But it hasn't been enough, and I'm still mucking about! So what am I missing?

share|improve this question

marked as duplicate by slhck Apr 18 '13 at 8:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Do you have a .bash_profile? – slhck Apr 18 '13 at 7:37

1 Answer 1

  1. .profile file does not get reloaded automatically - it gets loaded on startup, or manually. Try opening terminal and issuing a source ~/.profile. Then try set | grep PATH to verify the PATH variable.
  2. My .profile file does not contain quotes around the paths. Try removing them, saving the file and goto 1.
share|improve this answer
The quotes don't matter and the OP said they had already tried removing them. – slhck Apr 18 '13 at 7:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.