Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

At first, I've downloaded ffmpeg 0.6.5. and it works. But when I'm trying to use '-vf' option, Terminal said there's no such command.

So I asked this on Super User and someone said that the cause is my ffmpeg version being too old.

So here's what I want to do: upgrade my ffmpeg 0.6.5 to 1.2. Below is what I've tried.

  1. Download and install yasm and ffmpeg-1.2
  2. Execute ./configure in my folder where ffmpeg has downloaded.
  3. Execute make command.
  4. Execute make install command.

There's no error while I proceed, but when I enter the command ffmpeg -version it still shows 0.6.5. What can I do?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

This was a path problem. Originally ffmpeg is installed in the directory where the gz file(or bz2) is.

So if you do ./configuremakemake install, it works, but only in that directory (for this case it was /home/username/Downloads/ffmpeg-1.2).

If you want to use the ffmpeg command anywhere, you give some options to the ./configure command, like .configure --prefix=/usr.

So, that's the way I worked it out.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.