Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is a very simplistic question, but nonetheless it is annoying several of my users.

Our company is fairly small and consists of about 5 users with Windows XP workstations. The profiles are local profiles, nothing is on a domain. The workstations are configured for the "classic" login style with a username and password text box rather than the welcome screen. This is all fine and good, but XP doesn't remember the last username, which makes it a pain on systems where only one user is on the system (in other words, all of them). It defaults to "user" and places the cursor in the password field automatically, so every time a user wants to log in they have to clear out the username field, type their name, then go down to password.

How can I set XP to remember their usernames? I was under the impression that this was the default behavior, but apparently not.

share|improve this question
add comment

3 Answers

up vote 5 down vote accepted

I think this is in the Local Security Policy. Have a look in there. It was turned off (probably in SP2) for security reasons.

Yup - Local Policies > Security Options > Interactive Logon: Do not display last user name.

share|improve this answer
    
This sounds exactly like what I need, but unfortunately, stand-alone XP Pro workstations don't appear to have the group policy editor required to perform this. –  DWilliams Oct 21 '09 at 16:59
    
To clarify, it is not found under administrative tools and is not available to select as a MMC snap-in. –  DWilliams Oct 21 '09 at 17:02
3  
They do. Start -> Run -> gpedit.msc –  djhowell Oct 21 '09 at 17:02
    
I was unable to locate the group polity editor, even entering its command directly. My best guess is that I got overzealous removing components with nLite when making my install CD. Accepting this answer because in all probability it works on a normal installation. –  DWilliams Nov 10 '09 at 17:22
    
That's a shame. Good luck with your anticipated rebuild (including Local Security Policy) :-) –  user3463 Nov 10 '09 at 20:23
add comment

Perform the following steps in the link:

http://support.microsoft.com/kb/307882

To open and edit your Local Policy, then perform the steps listed previously.

share|improve this answer
    
That is a really helpful site for security settings. thanks for sharing that. –  Doltknuckle Oct 21 '09 at 21:09
add comment

Under Windows 7 this is in a difference place. Start the Local Group Policy Editor by going to Start -> Run... and type gpedit.msc. Then go to Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> Security Options -> Interactive logon: Do not display last user name

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.