Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Assuming you have a password that includes the @ sign – how do you enter that in the Windows 7 logon screen?

The workaround I have found so far is to use ALT+6+4 (on the number pad). This works, but is cumbersome.

I am guessing that this is a non-issue on a US keyboard? Does it work?

On the keyboard I am using (Swiss German) you need to press ALTGR+2 to get the @ symbol and the logon screen does not recognize this combination – it doesn't add a character bullet to the text box.


Update: This morning I tried to login and everything just worked. Bummer. That was the lock screen, though. So next, I logged out and there: I can't do any ALTGR combinations (so that rules out the German-German hypothesis) – but SHIFT+2 does work. Hm…

share|improve this question
    
Check the upper-left corner of the login screen for the language/keyboard menu and make sure that it's set correctly for your keyboard. –  Bradd Szonye Apr 18 '13 at 7:59
1  
Does shift+2 work? –  terdon Apr 18 '13 at 8:48
    
Have you tried "Ease of Access" - On Screen Keyboard? –  MSalters Apr 19 '13 at 8:59

2 Answers 2

up vote 2 down vote accepted

Verify that you already have your Swiss layout at logon. If it seems to be German (Z vs. Y), maybe try AltGrQ for the @ (German-German).

This is the registry key where Windows 7 sets the layouts used at logon:

HKEY_Users\.Default\Keyboard Layout\Preload

German has the code 407. Swiss (German) should be 807 according to this list (Thanks MSalters and Daren Thomas for the enlightenment and yes your link is the better one).

How to...

share|improve this answer
    
wow. i have a HKEY_Users\.Default\Keyboard Layout\Preload\1set to 409, which is Ukranian. scary... switched it to 0001041F and now I'm locked out :( –  Daren Thomas Apr 19 '13 at 7:36
    
ok. so this works, except that the list shown on the page linked to by @TheUser1024 might be buggy... this one worked better: windowsitpro.com/systems-management/… (and it also states that 409 is English (United States), which makes a lot more sense...) –  Daren Thomas Apr 19 '13 at 7:52
    
There might be some confusion between hexadecimal and decimal numbers. This Microsoft table is more detailed and lists both. –  MSalters Apr 19 '13 at 9:01

Set your system profile's regional settings to match yours:

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.