Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Safari 5.1.7 installed on my system.I have installed and set default email client Mozilla Thunderbird.

I have an application which has link like

<a href="mailto:someone@example.com">email</a>

This works fine in Chrome,Opera,IE and Firefox.But does not work in Safari.

How to fix this.I searched on Google for this.There it is suggested that we should set an email client for Safari. But I am unable to set email client for safari. See the screenshotenter image description here

I am using windows 7 as Operating system Using Default Programs setting of windows I have set Thunderbird as default email client. Thanks

share|improve this question

migrated from stackoverflow.com Apr 18 '13 at 10:27

This question came from our site for professional and enthusiast programmers.

2 Answers 2

You need to install the mailto extension in order to achieve that.

See here: https://sites.google.com/site/mailtoextension/

share|improve this answer
    
The link given on the url provided by you is not working –  Muk Apr 18 '13 at 9:10
    
@Muk Hmm really? It works for me. Try this one sites.google.com/site/mailtoextension/… –  mattytommo Apr 18 '13 at 9:11
    
@mattyommo When i click on "Click here to download your attachment." this error comes "This webpage is not available". –  Muk Apr 18 '13 at 9:13
    
@Muk Weird, there are a few more download links on Google. Try this one softpedia.com/progDownload/… –  mattytommo Apr 18 '13 at 9:15
    
Is there any other way apart from extension.I am running this safari on windows 7? –  Muk Apr 18 '13 at 9:17

You set the default mail client in Mail I believe, or maybe in System Preferences. I don't have a Mac here, so cannot check. In Mail you set Thunderbird as default mail client.

share|improve this answer
5  
Neither does the OP. (If you look at the screenshot you'll see the browser is running on Windows.) –  Juhana Apr 18 '13 at 8:49
    
Sorry, hadn't noticed that! –  SPRBRN Apr 18 '13 at 8:50
    
Is there any other way apart from extension.I am running this safari on windows 7 –  Muk Apr 18 '13 at 9:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.