Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with Emacs on my Linux Mint.

When I make an apt-get upgrade or apt-get -f install, I have this error message :

Paramétrage de emacsen-common (2.0.3) ...
/var/lib/dpkg/info/emacsen-common.postinst: 40: /var/lib/dpkg/info/emacsen-common.postinst: /usr/lib/emacsen-common/emacs-package-install: not found
dpkg: erreur de traitement de emacsen-common (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 127
dpkg: des problèmes de dépendances empêchent la configuration de emacs23-common :
 emacs23-common dépend de emacsen-common (>= 1.4.10) ; cependant :
 Le paquet emacsen-common n'est pas encore configuré.

dpkg: erreur de traitement de emacs23-common (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de emacs23-bin-common :
 emacs23-bin-common dépend de emacs23-common (= 23.4+1-4ubuntu1) ; cependant :
 Le paquet emacs23-common n'est pas encore configuré.

dpkg: erreur de traitement de emacs23-bin-common (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de emacs23 :
 emacs23 dépend de emacs23-bin-common (= 23.4+1-4ubuntu1) ; cependant :
 Le paquet emacs23-bin-common n'est pas encore configuré.

dpkg: erreur de traitement de emacs23 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de emacs24-common :
 emacs24-common dépend de emacsen-common (>= 1.4.10) ; cependant :
 Le paquet emacsen-common n'est pas encore configuré.

dpkg: erreur de traitement de emacs24-common (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de emacs24-bin-common :
 emacs24-bin-common dépend de emacs24-common (= 24.1+1-2ubuntu3) ; cependant :
 Le paquet emacs24-common n'est pas encore configuré.

dpkg: erreur de traitement de emacs24-bin-common (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de emacs24 :
 emacs24 dépend de emacs24-bin-common (= 24.1+1-2ubuntu3) ; cependant :
 Le paquet emacs24-bin-common n'est pas encore configuré.

dpkg: erreur de traitement de emacs24 (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 emacsen-common
 emacs23-common
 emacs23-bin-common
 emacs23
 emacs24-common
 emacs24-bin-common
 emacs24
E: Sub-process /usr/bin/dpkg returned an error code (1)

emacs24* and emacs23* arn't correctly uninstalled but I the others are upgraded. What can I do to solve this ? I tried many solutions I found but nothing works...

Thank you.

share|improve this question

migrated from stackoverflow.com Apr 18 '13 at 15:47

This question came from our site for professional and enthusiast programmers.

1 Answer 1

There was an error configuring emacsen-common. This caused all of the packages which depend upon emacsen-common (all the other packages) to fail. You need to fix the issue with emacsen-common, and then run sudo apt-get -f install to finish things up.

As to how to fix the error with emacsen-common, check the error message provided on line 2 of the output you posted:

/usr/lib/emacsen-common/emacs-package-install: not found
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.