Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a dell xps 1530 laptop. The laptop initially came with windows vista. However, I once upgraded to Win 7 64 bit and it was working alright till I started having problems with a few software that I wanted to use. Then I went and got me the win 7 32 bit. Afterwards, I started experiencing a few problems. One of the main problems I have is that my battery now will not charge at all.

Once I plug it in, it shows in the task bar that the plug is in but it has an plug and a red x icon that is telling me that the laptop is plugged in but it will not charge or hold a charge for that matter. Therefore, I checked the battery and the battery seems to be fine with 3 lights blinking that is telling me that it has a charge on it. However, the laptop never recognizes this. Moreover, if I unplug the AC cord, the laptop will automatically shut off. As a result, I know it can't be the AC cord since it works when it is plugged in and its from Dell.

Lastly, when the AC cord gets yanked off the laptop by accident, it shutsoff. Then when I power it back on, the time and date always goes back to year May, 1, 2008.

With this said, I don't know why it resets itself to May 1, 2008 and am thinking it might be a bios problem but if it is, I cant update the BIOS due to the lack of battery, which is required for a bios update. Also, since the battery worked and AC worked I don't what is causing this to happen and not allow the battery to charge. I am thinking is either a software problem or a hardware (motherboard) problem. Any help would be greatly appreciated.

share|improve this question
    
If the date resets every time you pull the plug, then it sounds to me like your CMOS battery is bad. Replacing those is not usually hard, but it does require at least partially dismantling the computer. –  techturtle Apr 18 '13 at 16:03
2  
I would just replace the battery. If the battery is not charging then the PCB board within the battery is likely dead. This tells the internals PCB board in the laptop the status of the battery. In other words the battery is dead, even if it has a charge, its still dead. –  Ramhound Apr 18 '13 at 16:24
    
@techturtle thanks I will try this first, I first guess was this but I wanted to other peoples take on it as well. –  Totti Apr 22 '13 at 0:32
    
@Ramhound I think you are right but it was working before the OS downgrade from win7 64 to 32bit... so ill replace the battery as a next step. thanks for your input though –  Totti Apr 22 '13 at 0:32
    
@Totti - The battery is at least 5 years old if it came with Windows Vista installed on the laptop. The behavior you describe indicates the battery is dead and/or has no ability to charge. The clock problem is a BIOS battery problem easy enough to resolve. If you have the OEM software installed there should be no technical reason it shouldn't work. After all your original installation came with 32-bit Windows Vista. –  Ramhound Apr 22 '13 at 11:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.