Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

By default, when one holds down Alt and drags with the mouse, it will move a window in KDE/kwin. Is there a way to disable this for a particular application?

I know there's a lot of application overrides (click top left window icon > Advanced > Special Application Settings), but I can't find one to disable this alt key. The closest I can find is to disable global keyboard shortcuts.

share|improve this question
    
Actually, the primary motivation for my question is now nil. I wanted to use the alt keys when running x2go, but I think the problem was in fact that the server wasn't using the alt+drag actions. When I switched from gnome-desktop to unity (by running sudo apt-get install ubuntu-desktop on the server), everything started to work as expected -- the alt keys now interact with the "guest" windows in x2go, rather than my client desktop's windowing system. –  gatoatigrado Apr 18 '13 at 22:58

1 Answer 1

In the KDE System Settings for Window Behavior, change the Window Actions for Inner Window, Titlebar, & Frame. With the modifier key set to Alt, set the left button to Nothing. You can also reassign the action to a different modifier key.

See also: https://bbs.archlinux.org/viewtopic.php?id=109085

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.