Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've two screens next each other and I'm running Gnome (Metacity 2.22). I use Xinerama to setup resolution and position for the screens. Using OpenSuse 11.1.

I would like to use the keyboard to move windows from one screen to the other one. I found some apparently useful keys under gconf-editor:

* /apps/metacity/window_keybindings/move_to_side_n
* /apps/metacity/window_keybindings/move_to_side_e
* /apps/metacity/window_keybindings/move_to_side_w
* /apps/metacity/window_keybindings/move_to_side_s

I setup some bindings, but they seem not to work properly for all windows (for example, with Firefox or Thunderbird). Sometimes, the windows return to their original position when I press a key.

Do you have any other alternative to easily move windows across multiple screens (and possibly to tile them?). I would prefer to keep the Gnome window manager, not to switch to ratpoison or whatever else.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

If your screens are on separate workspaces, you can use Shift + Ctrl + Alt and an arrow key in the specified direction you wish to move it.

share|improve this answer
    
This could be a solution. How can I map the two screens to different workspaces? –  Roberto Aloi Oct 23 '09 at 9:16
    
Uncheck the "Mirror" checkbox in display preferences. –  John T Oct 23 '09 at 13:20

If your bindings are working normally except under certain windows, this might mean that whatever window it is uses that binding for something else and is hijacking the shortcut. Try again by setting a different key combination, or disable the offending key combination in Firefox/whatever.

share|improve this answer
    
I actually think it must be something different. For example, with the terminal window, if I move into a different screen, then I maximize the window, the terminal goes back into the original screen. Then I need to move it back. It seems a bit awkward. My feeling is that the original position for maximize/minimize is somehow "cached" somewhere and it's not updated when using my key bindings. –  Roberto Aloi Oct 23 '09 at 9:15

You can use the compiz PUT plugins to set the keyboard shortcut for Put To Next Output

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.