Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I first switched to ZSH when I would use the up arrow key to move through history it would filter the history based on what I had already typed so if I type mysql and then up I would be stepping through recent commands that started with mysql.

This is no longer the case, now if I use up it just steps thought the most recent commands regardless of what I've already typed. How can I turn this back on?

My .zshrc is very small and I've already tried turning all my options off.

Here is what is in my .zshrc

plugins=(git command-not-found svn debian screen vi-mode)
source $ZSH/oh-my-zsh.sh

bindkey -v
bindkey "^R" history-incremental-search-backward
export EDITOR="vim"

# history stuff
HISTFILE=~/.zsh-histfile
HISTSIZE=2000
share|improve this question

migrated from stackoverflow.com Apr 19 '13 at 15:18

This question came from our site for professional and enthusiast programmers.

    
"My .zshrc is very small" except that whole oh-my-zsh bit... –  jcm Jun 7 at 22:44

1 Answer 1

up vote 4 down vote accepted

You had up-line-or-search bound to your up-arrow. This should do what you want:

bindkey '^[[A' up-line-or-search
bindkey '^[[B' down-line-or-search
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.